qemu-trivial
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-trivial] [PATCH] Rename get_tls to tls_var


From: Paolo Bonzini
Subject: Re: [Qemu-trivial] [PATCH] Rename get_tls to tls_var
Date: Mon, 05 Dec 2011 15:24:03 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20110930 Thunderbird/7.0.1

On 12/05/2011 03:18 PM, Jan Kiszka wrote:
get_tls() can serve as a lvalue as well, so 'get' might be confusing.

Signed-off-by: Jan Kiszka<address@hidden>
---
  cpu-all.h  |    2 +-
  qemu-tls.h |    4 ++--
  2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/cpu-all.h b/cpu-all.h
index 5f47ab8..8888016 100644
--- a/cpu-all.h
+++ b/cpu-all.h
@@ -336,7 +336,7 @@ void QEMU_NORETURN cpu_abort(CPUState *env, const char 
*fmt, ...)
      GCC_FMT_ATTR(2, 3);
  extern CPUState *first_cpu;
  DECLARE_TLS(CPUState *,cpu_single_env);
-#define cpu_single_env get_tls(cpu_single_env)
+#define cpu_single_env tls_var(cpu_single_env)

  /* Flags for use in ENV->INTERRUPT_PENDING.

diff --git a/qemu-tls.h b/qemu-tls.h
index 5b70f10..b92ea9d 100644
--- a/qemu-tls.h
+++ b/qemu-tls.h
@@ -41,12 +41,12 @@
  #ifdef __linux__
  #define DECLARE_TLS(type, x) extern DEFINE_TLS(type, x)
  #define DEFINE_TLS(type, x)  __thread __typeof__(type) tls__##x
-#define get_tls(x)           tls__##x
+#define tls_var(x)           tls__##x
  #else
  /* Dummy implementations which define plain global variables */
  #define DECLARE_TLS(type, x) extern DEFINE_TLS(type, x)
  #define DEFINE_TLS(type, x)  __typeof__(type) tls__##x
-#define get_tls(x)           tls__##x
+#define tls_var(x)           tls__##x
  #endif

  #endif

Good idea.

Paolo



reply via email to

[Prev in Thread] Current Thread [Next in Thread]