[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Aeskulap-users] Compiling on FC4 x86_64 (undefined symbol: numberOf

From: Amir Seginer
Subject: Re: [Aeskulap-users] Compiling on FC4 x86_64 (undefined symbol: numberOfDcmStorageSOPClassUIDs)
Date: Tue, 03 Oct 2006 00:33:30 +0200
User-agent: Mozilla Thunderbird 1.0.8-1.1.fc4 (X11/20060501)

It works now.


One feature request, now that I can run the program. I saw that measurement tools are planned for the future. I don't know how useful this is to others, but can one include coordinates to track the cursor on the image? I mean reporting the cursor position on the image in RAS coordinate system (not just reative to a specific image).

Alexander Pipelka wrote:
Ok. I think I got it.

Aeskulap got linked with your preinstalled dcmtk version.
I guess this preinstalled version is a static library, right ?

I think i have to modify the name of the packaged dcmtk version to avoid
these linking conflicts.

As a workaround you could remove the currently installed dcmtk version
and *then* build aeskulap again. After that you can install your current
dcmtk version again.


Am Montag, den 02.10.2006, 20:47 +0200 schrieb Amir Seginer:

Thanks for the quick reply.

Alexander Pipelka wrote:


It looks like a compiler related issue.
Which gcc version are you using ?

I'm using: gcc-4.0.2-8.fc4

The "numberOfDcmStorageSOPClassUIDs" is a variable that should be
exported by the DCMTK libraries. For some reason it isn't, ...
Is this one the *only* unresolved symbol ?

Could you please try a "make install" and do the following afterwards:

ldd -r /usr/bin/aeskulap
ldd -r /usr/lib/aeskulap/

Asuming you prefix is "/usr"

No, it seems it is not the only one missing. Attached is a zipped output of the commands you sent (my prefix is /usr/local).

Note, that I do NOT seem to have under /usr/local after running 'make install'. (I ran ldd on the copy in compliation directory)

If it helps in any way I have installed dcmtk-3.5.4-1 and dcmtk-devel-3.5.4-1 (build from source rpm).

Thanks again,



Am Montag, den 02.10.2006, 15:30 +0200 schrieb Amir Seginer:


I've been trying to compile aeskulap-0.2.1 on a Fedora Core 4 machine (x86_64). The compilation seems fine (to me), but when I run Aeskulap I get an error:

/home/amir/Work/DICOM-viewers/aeskulap-0.2.1/src/.libs/lt-aeskulap: symbol lookup error: /home/amir/Work/DICOM-viewers/aeskulap-0.2.1/imagepool/.libs/ undefined symbol: numberOfDcmStorageSOPClassUIDs

Any help would be appreciated. I can give more info if needed.



Aeskulap-users mailing list

Aeskulap-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]