[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX-devel] [PATCH v2]: Merge /preview/ into top-level

From: Matthew Leach
Subject: Re: [AUCTeX-devel] [PATCH v2]: Merge /preview/ into top-level
Date: Mon, 17 Nov 2014 19:08:09 +0000
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.0.50 (gnu/linux)

Uwe Brauer <address@hidden> writes:

> On 11/16/2014 11:25 PM, Mosè Giordano wrote:
>     Hi Matthew,
> 2014-11-16 17:05 GMT+01:00 Matthew Leach <address@hidden>:
>> Hi Mosè,
>> Thanks for the review.
>> Mosè Giordano <address@hidden> writes:
>>> Hi Matthew,
>>> there are still some references to files in "preview/" directory
>>> inside, rules "xemacs-package"
>> I've just tried to run:
>> $ make xemacs-package TAG=11.88
>> and failed with:
>> --8<---------------cut here---------------start------------->8---
>> Compiling /home/matthew/Development/auctex/xemacs-build/tex-jp.el...
>> While compiling toplevel forms in file 
>> /home/matthew/Development/auctex/xemacs-build/tex-jp.el:
>>   !! Symbol's value as variable is void ((hack-one-local-variable))
>>>>Error occurred processing tex-jp.el: Symbol's value as variable is void: 
>> Done
>> Makefile:158: recipe for target 'lisp' failed
>> make[1]: *** [lisp] Error 1
>> --8<---------------cut here---------------end--------------->8---
>> I get the same error with and without my patches applied.  Did you have
>> any problems making an xemacs package for the 11.88 release?
> No, I had no problem.  Which version of XEmacs do you use?  I have 21.4.22.
> Hi 

Hi Uwe,

> this is a mule problem. I bet Matthew is using a non mule xemacs

Thanks for the suggestion, I'm pretty sure I have an xemacs with MULE
support, though.

Output from config.log:
--8<---------------cut here---------------start------------->8---
configure:2197: checking for MULE support
/usr/bin/xemacs -batch -eval (let* ((x (condition-case nil (require 'mule )     
(error (prog1 nil (message "mule not found")))))) (write-region (if (stringp x) 
x (prin1-to-string x)) nil "./conftest-22439"))

Wrote /home/matthew/Development/auctex/xemacs-build/conftest-22439
=> mule
configure:2231: result: yes
--8<---------------cut here---------------end--------------->8---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]