[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem with RefTeX and the amsmath + mathtools styles

From: Florent Rougon
Subject: Problem with RefTeX and the amsmath + mathtools styles
Date: Sun, 29 Dec 2019 13:22:26 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (gnu/linux)


Following up on Arash's suggestion here:

I'm writing to you about a problem I encountered when I tried RefTeX a
few months ago. Please note that I was completely new to RefTeX, tried
it for a short period, then stopped because of this problem (basically,
I thought “Uh, RefTeX is a complex third-party package that interferes
badly with the already complex AUCTeX, this may bring me more trouble
than comfort, better stay with what the AUCTeX devs take care of.”).
However, it seems that RefTeX is maintained by the same AUCTeX
developers nowadays, so... this at least justifies this report.

Given the circumstances of this try-and-stop, I'm sorry to say thay I
don't understand the short RefTeX setup reproduced below anymore---it
may be that I copy/pasted the last chunk from the manual---and maybe it
doesn't make much sense to you either. Don't worry too much, my life
doesn't depend on this problem. :-) I am merely following up on Arash's
kind suggestion.

So, here are the minimal conditions I found that can trigger the

1) Install AUCTeX with:

   ./configure --prefix="$HOME/.local" \
               --with-lispdir="$HOME/lisp/manual-installs" \
   make install

   I verified all this with AUCTeX commit
   2ceda21f6a0d25f5d0b5aef2edcbac9d52b17150 from December 14, which is
   still the HEAD of the 'master' branch today.

2) ~/.emacs.d/init.el:

Attachment: init.el
Description: Emacs initialization file

3) Open the following test.tex:


Doing 3) fails with the error message:

  Symbol’s value as variable is void: LaTeX-amsmath-package-options

You'll find the corresponding backtrace attached. As noted in a comment
in the above ~/.emacs.d/init.el, if I add the AUCTeX Git repository path
to `load-path':

  (add-to-list 'load-path "~/src-pastouche/auctex.git")

but don't add the paths populated by 'make install':

  ; (add-to-list 'load-path "~/lisp/manual-installs")
  ; (add-to-list 'load-path "~/lisp/manual-installs/auctex")

then doing 3) doesn't trigger the error---but then maybe some things are
missing for AUCTeX to work properly. In that case, the tex-site.el file
loaded by the modified ~/.emacs.d/init.el is
~/src-pastouche/auctex.git/tex-site.el (i.e., it is the one at the root
of the AUCTeX source code repository).

Many thanks for maintaining AUCTeX!



Attachment: backtrace.txt
Description: Backtrace

reply via email to

[Prev in Thread] Current Thread [Next in Thread]