automake-commit
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Automake-commit] [SCM] GNU Automake branch, experimental/ng/check, crea


From: Stefano Lattarini
Subject: [Automake-commit] [SCM] GNU Automake branch, experimental/ng/check, created. v1.12-301-gcdf856e
Date: Tue, 22 May 2012 22:05:31 +0000

This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "GNU Automake".

http://git.sv.gnu.org/gitweb/?p=automake.git;a=commitdiff;h=cdf856e1fa9dfe802177ab1dc8e7074a6e49fbe7

The branch, experimental/ng/check has been created
        at  cdf856e1fa9dfe802177ab1dc8e7074a6e49fbe7 (commit)

- Log -----------------------------------------------------------------
commit cdf856e1fa9dfe802177ab1dc8e7074a6e49fbe7
Author: Stefano Lattarini <address@hidden>
Date:   Tue May 22 23:22:01 2012 +0200

    [ng] coverage: parallel-tests and dynamic $(TEST_EXTENSIONS) content
    
    The recent changes to the parallel-tests implementation should allow us
    to define or override TEST_EXTENSIONS with more dynamic contents; in
    particular, something like:
    
        TEST_EXTENSIONS = $(suffix $(TESTS))
    
    should now work smoothly.
    
    * t/test-extensions-dynamic.sh: New test.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit 74473ad76827f176375c0a021292acc9c75b0091
Author: Stefano Lattarini <address@hidden>
Date:   Tue May 22 22:37:34 2012 +0200

    [ng] cosmetics: improve comments and spacing in 'parallel-tests.am'
    
    * lib/am/parallel-tests.am: Fix some comment typos and missing
    capitalization; improve clarity through more use of vertical
    spacing; add a coupe of explicative comments.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit 4ddd693f6d67eda98f5428a6da587ef9f047b0ba
Author: Stefano Lattarini <address@hidden>
Date:   Tue May 22 22:34:11 2012 +0200

    [ng] check: support conditional $(TEST_EXTENSIONS)
    
    That is pretty easy to do with the current code base; just ...
    
    * automake.in (handle_tests): ... stop erroring on conditional contents
    of TEST_EXTENSIONS, and move the definitions of a default TEST_EXTENSIONS
    variable ...
    * lib/am/parallel-tests.am: ... in here.
    * t/test-extensions-cond.sh: Rewritten to adapt to the new semantic.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit e3bd91eac3b30dd450e5524954da2393eb017591
Author: Stefano Lattarini <address@hidden>
Date:   Tue May 22 21:38:44 2012 +0200

    [ng] check: accept dot-less entries in $(TEST_EXTENSIONS)
    
    Since the beginning of the parallel-tests harness, we've been requiring
    that the entries in $(TEST_EXTENSIONS) begin with a dot (as suggested by
    the name "extensions").  But it's clear that if an user writes something
    like:
    
        TEST_EXTENSIONS = test sh
    
    he actually means:
    
        TEST_EXTENSIONS = .test .sh
    
    So let's try to be more user-friendly, and some DWIM processing on the
    content of $(TEST_EXTENSIONS).
    
    * automake.in (is_valid_test_extension): Drop this, it's a no-op now.
    (handle_tests): Don't call that anymore.  Simplify accordingly.
    Drop the '%INVALID_TEST_EXTENSIONS%' transform when processing ...
    * lib/am/parallel-tests.am: ... this file.  Drop warnings about invalid
    test extensions.  Enhance so that it can deal with dot-less entries in
    $(TEST_EXTENSIONS), with the semantics explained above, with the help
    of ...
    (am__dotted_test_extensions, am__dotless_test_extensions): ... these new
    internal variables (memoized).
    (am__tpfx): Simplified accordingly.
    (am__get_test_bases): Adjust to use '$(am__dotted_test_extensions)'
    instead of bare '$(TEST_EXTENSIONS)'.
    * t/test-extensions-funny-chars.sh: Adjust a little, to enhance coverage.
    * t/parallel-tests-internals.sh: Adjust and extend.
    * t/test-extensions.sh: Remove as obsolete.
    * Makefile.am (XFAIL_TESTS): Drop the removed test.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit 9a9f7b596c1e94eb90d07e09af6dc4bad1b771a9
Author: Stefano Lattarini <address@hidden>
Date:   Tue May 22 18:28:49 2012 +0200

    [ng] check: be laxer in accepted $(TEST_EXTENSIONS)
    
    Relax our checks on the contents of $(TEST_EXTENSIONS) by simply
    verifying that every entry there starts with a dot.
    
    The only reasons the restriction on the $(TEST_EXTENSIONS) was in
    place was to ensure the relevant LOG_COMPILER, LOG_DRIVER, etc.,
    variables derived from an extension had valid names according to
    POSIX; but this is overkill for GNU make, since for it variables
    names can happily contain "funny" characters as well (e.g., '!',
    '@', '-', ...).
    
    Maybe in the future we could start to again complain about truly
    problematic characters (like '$', '=' or ','), but let's not
    over-engineer for the moment.  After all, mainline Automake had
    suffered from a similar limitation in the long-lived version 1.11
    (until commit v1.11-476-g90bea64 of 2011-10-01, "parallel-tests:
    automake error our on invalid TEST_EXTENSIONS"), and nobody had
    ever complained.
    
    * automake.in (is_valid_test_extension): Be much laxer: accept
    all the strings beginning with a dot, in addition to the @EXEEXT@
    substitution.
    * t/test-extensions-funny-chars.sh: New test.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit e5d1890ba1b3a5d83fd4b133d144c1ff38b5b681
Author: Stefano Lattarini <address@hidden>
Date:   Tue May 22 17:01:12 2012 +0200

    [ng] check: logic to define *LOG_DRIVER vars moved to generated Makefiles
    
    If a LOG_DRIVER variable is undefined, we should define a default for it,
    pointing to the "simple" test driver ('lib/test-driver' in the automake
    repository).  Move the logic to do so out of the automake script and into
    the generated Makefiles.
    
    * automake.in (handle_per_suffix_test): Remove.
    (handle_tests): Don't call it anymore, and simplify accordingly.
    * lib/am/parallel-tests.am (am__handle_per_suffix_test): Define the
    relevant LOG_DRIVER variable to a proper default if it is undefined.
    * t/test-driver-cond.sh: Remove obsolete grepping checks.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit 9a5f837c23a659931ad8ea03242d633e3678392d
Author: Stefano Lattarini <address@hidden>
Date:   Tue May 22 16:21:28 2012 +0200

    [ng] warns: don't report possible issues with '_DEPENDENCIES' variables
    
    This will allow us to move (in future changes) some more processing at
    make runtime, without having automake complain spuriously (which couldn't
    be avoided, as to avoid such complaints automake should have access to
    context and information only available at make runtime -- which is clearly
    impossible).
    
    * NG-NEWS: Document that Automake-NG can be weaker than mainline Automake
    in diagnostic and early error detection; and also explain why it is so.
    * automake.in (check_typos): Don't check for possible typos in the
    '_DEPENDENCIES'.
    Consequently, don't bother calling 'set_seen' ...
    (handle_per_suffix_test): ... on the 'LOG_DEPENDENCIES' variables ...
    (scan_aclocal_m4): ... nor on the 'CONFIG_STATUS_DEPENDENCIES' and
    'CONFIGURE_DEPENDENCIES' variables ...
    (handle_tags): ... nor on the 'TAGS_DEPENDENCIES' variable ...
    (handle_ltlibraries): ... nor on the 'libfoo_la_DEPENDENCIES' nor
    the 'EXTRA_libfoo_la_DEPENDENCIES' variables ...
    (handle_libraries): ... nor on the 'libfoo_a_DEPENDENCIES' nor the
    'EXTRA_libfoo_a_DEPENDENCIES' variables ...
    (handle_programs): ... nor on the 'program_DEPENDENCIES' nor the
    'EXTRA_program_DEPENDENCIES' variables.
    * t/vartypos.sh, t/vartypo2.sh: Relax accordingly.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit 20a1ce3d6b61c97536b701a52961ef8fa342677d
Author: Stefano Lattarini <address@hidden>
Date:   Tue May 22 15:20:48 2012 +0200

    [ng] refactor: merge check2.am into parallel-tests.am
    
    Another change aimed at moving logic and processing out of automake
    and inside the generated Makefiles.  This is mostly a preparatory
    step.
    
    * lib/am/check2.am: Merged ...
    * lib/am/parallel-tests.am: ... in here, with the (several) required
    adjustments and extensions.
    * Makefile.am (dist_am_DATA): Adjust.
    (XFAIL_TESTS): Add 't/test-extensions.sh'.
    * automake.in (handle_per_suffix_test): Don't process nor include
    'check2.am' anymore.
    * t/parallel-tests-internals.sh: New test.
    * t/serial-tests.sh: Adjust grepping checks.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit 993f03a12d68efb489d6cbe8c7943cf61b1000a5
Author: Stefano Lattarini <address@hidden>
Date:   Tue May 22 14:33:52 2012 +0200

    [ng] am: new make variable '$(am__handle_exeext)'
    
    This is just a preparatory commit in view of future changes.
    
    * lib/am/header-vars.am (am__handle_exeext): New internal variable,
    defined to "yes" if the automake static conditional '?HANDLE-EXEEXT?'
    is true, and to "no" otherwise.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit 8c64f4c94278dbb66b33aeb3c396c6b1fd04387a
Author: Stefano Lattarini <address@hidden>
Date:   Tue May 22 01:48:52 2012 +0200

    [ng] check: unconditionally distribute test-driver
    
    This new behaviour is suboptimal, but will allow us to move yet more
    logic and processing from the automake scripts into the generated
    Makefiles.
    
    * automake.in (handle_tests): Distribute 'test-driver' unconditionally
    if the variable TESTS is defined and the 'serial-tests' option is not
    used.
    (handle_per_suffix_test): Don't distribute 'test-driver' anymore.
    * Several tests: Adjust.
    * t/test-driver-custom-no-extra-driver.sh: Remove as obsolete.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit 9c259ea642d885b8a6b5f3414e7e0016752b9c91
Author: Stefano Lattarini <address@hidden>
Date:   Tue May 22 01:37:28 2012 +0200

    [ng] check: warn about invalid TEST_EXTENSIONS at make runtime
    
    * automake.in (handle_tests): Instead of warning about invalid test
    extensions at Automake runtime, pass their list through the transform
    '%INVALID_TEST_EXTENSIONS%' to ...
    * lib/am/parallel-tests.am: ... this file, that will warn at make
    runtime if that list is not empty.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit 6b33d2b1922a0cbcd2141c31d13748b4661ffad0
Author: Stefano Lattarini <address@hidden>
Date:   Tue May 22 01:11:42 2012 +0200

    [ng] check: separate serial and parallel harnesses in distinct '.am' files
    
    This is just code reordering.  No semantic change is intended.
    
    * lib/am/check.am: Split out ...
    * lib/am/parallel-tests.am, lib/am/serial-tests.am: ... into these
    two files.
    * automake.in (handle_tests): Adjust.
    * Makefile.am (dist_am_DATA): Likewise.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit c3eb27283dbe3328f333b3344c11216f788974d2
Author: Stefano Lattarini <address@hidden>
Date:   Tue May 22 00:58:58 2012 +0200

    [ng] check: move definition of console colors in its own '.am' fragment
    
    This is only meant to simplify future changes.  No semantic change is
    intended.
    
    * lib/am/check.am: Include ...
    * lib/am/check.am (am__tty_colors, am__tty_colors_dummy): Move out to ...
    * lib/am/color-tests.am: ... this new file.
    * Makefile.am (dist_am_DATA): Adjust.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit 9a16c3c08bdc2d26f64ee513c0796b75b50b1a4e
Author: Stefano Lattarini <address@hidden>
Date:   Mon May 21 23:27:55 2012 +0200

    [ng] refactor: make '$am_config_aux_dir' available as a make variable
    
    This API improvement will become useful in future changes.
    
    * automake.in (generate_makefile): Define an internal make variable
    '$(am__config_aux_dir)', holding value '$am_config_aux_dir' computed
    at Automake time.
    (All users): Adjusted.
    * t/distcom2.sh: Adjust.
    * t/distcom-subdir.sh: Likewise.
    * t/yacc-auxdir.sh: Likewise.
    * t/auxdir.sh: Adjust and simplify.
    * t/auxdir6.sh: Likewise.
    * t/auxdir7.sh: Likewise.
    * t/auxdir8.sh: Likewise.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit cf8fc13a4f3ff8d03cdb93019e5d5c2796937dca
Author: Stefano Lattarini <address@hidden>
Date:   Mon May 21 23:15:31 2012 +0200

    [ng] am: implement $(am__tolower) and $(am__toupper)
    
    These new make functions will be useful in future changes.
    
    * lib/am/header-vars.am (am__toupper, am__tolower): New make functions.
    * t/internals.tap: Test them.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit c868a21c22ae33e037c6dcb0ec42d758d8be9d12
Author: Stefano Lattarini <address@hidden>
Date:   Mon May 21 22:40:34 2012 +0200

    [ng] tests: get rid of an almost-obsolete test case (parallel-tests related)
    
    * t/posixsubst-tests.sh: Remove this test, merging the still-relevant
    parts of it ...
    * t/parallel-tests-dynamic.sh: ... in here.  Since we are at it, make
    existing grepping checks on "make check" output slightly stricter.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit 3dee480d80bab18f527c483c73523edc53a58e9c
Author: Stefano Lattarini <address@hidden>
Date:   Mon May 21 22:23:56 2012 +0200

    [ng] serial-tests: simplify automake-time preprocessing
    
    Prefer make-time and recipe-time processing instead.  Note that this
    change does not (nor is meant to) offer any simplification nor performance
    enhancement (in fact, it actually complicates the code); its purpose is
    to continue the trend of "move logic and knowledge out of the automake
    script and into the generated Makefiles".
    
    * NG-NEWS: Report that $(TESTS) and $(XFAIL_TESTS) are not rewritten
    anymore for $(EXEEXT) appending.
    * automake.in (handle_tests): Don't rewrite TESTS nor XFAIL_TESTS
    anymore.
    * lib/am/check.am: If 'EXEEXT' AC_SUBST is used, process $(TESTS) and
    $(XFAIL_TESTS) for $(EXEEXT) appending (for entries that are also
    compiled programs).  Do so with the help of ...
    (am__check_cook_with_exeext_1, am__check_cook_with_exeext): ... this
    new internal make functions, and place the processed content into
    (am__cooked_tests, am__cooked_xfail_tests): ... these new internal
    variables respectively.
    (check-TESTS): Depend on and use $(am__cooked_tests) rather than
    plain $(TESTS).  While we are at it, remove some code duplication
    with the help of the new 'is_xfail_test' shell function.
    * t/check5.sh: Adjust and extend.
    * t/check7.sh: Likewise.
    * t/serial-tests.sh: Adjust.
    * t/exeext4.sh: Adjust.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

commit 4faacc9ba39b9d5e27eb598653d4089055af0c2c
Author: Stefano Lattarini <address@hidden>
Date:   Mon May 21 19:16:10 2012 +0200

    [ng] am: new private make variable $(am__all_progs)
    
    This is just a preparatory refactoring for future changes.
    
    * automake.in (generate_makefile): Substitute $(am__all_progs) to the
    list of all programs "seen" by automake (by looking at the PROGRAMS
    primary).
    * t/all-progs.sh: New test.
    
    Signed-off-by: Stefano Lattarini <address@hidden>

-----------------------------------------------------------------------


hooks/post-receive
-- 
GNU Automake



reply via email to

[Prev in Thread] Current Thread [Next in Thread]