[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Undefined versioned symbol name __xstat64@@GLIBC_2.2

From: William A. Gatliff
Subject: Undefined versioned symbol name __xstat64@@GLIBC_2.2
Date: Tue, 2 Oct 2001 09:47:29 -0500
User-agent: Mutt/1.2.5i


I'm trying to build a solaris2.8-hosted i386-linux toolchain.  When I
build the i386-linux glibc-2.24 or glibc-2.2.2, I get this error
(reformatted for clarity):


i386-linux-gcc -nostdlib -nostartfiles -shared -o \
/export/home/bgat/sun1/build-glibc/elf/ld.so \
/export/home/bgat/sun1/build-glibc/elf/librtld.os \
-Wl,--version-script=/export/home/bgat/sun1/build-glibc/ld.map \

/export/home/bgat/sun1/build-glibc/elf/ld.so: undefined versioned
symbol name __xstat64@@GLIBC_2.2
/export/home/bgat/H-sparc-sun-solaris2.8/i386-linux/bin/ld: failed to
set dynamic section sizes: Bad value
collect2: ld returned 1 exit status
make[2]: *** [/export/home/bgat/sun1/build-glibc/elf/ld.so] Error 1

My build setup is as follows:

generic solaris2.8 setup, with GNU make, sed, awk, shutils, and native gcc

My cross toolchain looks like this:

binutils 2.10.1 (also tried 2.11.2, with same error)
glibc-2.2.4 and 2.2. (both with linuxthreads)
linux 2.4.3

The i386-linux-gcc referenced in the error message is a bootstrap

I'm stuck.  It isn't totally clear to me what the actual error is, or
how to correct it.  I suspect I'm missing a few entries in some kind
of symbol version file deep inside glibc, but that's just speculation
on my part.  Suggestions?

As a sanity check, I have built a linux-hosted i386-linux toolchain
using the same build script.


Bill Gatliff

reply via email to

[Prev in Thread] Current Thread [Next in Thread]