[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

glibc 2.2.5 problem solved

From: M. Shell
Subject: glibc 2.2.5 problem solved
Date: Sun, 07 Apr 2002 23:00:38 -0400

 I sent in a bug report a day or two ago and I wanted you to know that I
fixed the problem that I had with glibc 2.2.5 make check.

My system is a: Red Hat 6.0 on 400MHz K6-2 with 256MB, 
Linux kernel version 2.4.1

current glibc 2.2.1
make 3.79
gcc 2.96
binutils 2.10.91
texinfo info 3.12f
awk 3.0.3
perl 5.005_03
sed 3.02
autoconf 2.13
gettext 0.10.38-7

glibc addons: Linuxthreads


./configure --enable-add-ons --with-headers=/usr/src/linux/include --prefix=/usr



All went well. Then:

make check


gcc test-tgmath.c -c -O2 -Wall -Winline -Wstrict-prototypes -Wwrite-strings -g  
 -fno-builtin  -Wno-uninitialized -D__NO_MATH_INLINES 
-D__LIBC_INTERNAL_MATH_INLINES -I../include -I.  -I.. -I../libio  
-I../sysdeps/i386/elf -I../linuxthreads/sysdeps/unix/sysv/linux/i386 
-I../linuxthreads/sysdeps/unix/sysv/linux -I../linuxthreads/sysdeps/pthread 
-I../sysdeps/pthread -I../linuxthreads/sysdeps/unix/sysv 
-I../linuxthreads/sysdeps/unix -I../linuxthreads/sysdeps/i386/i586 
-I../linuxthreads/sysdeps/i386 -I../sysdeps/unix/sysv/linux/i386 
-I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common 
-I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../sysdeps/unix/sysv/i386 
-I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../sysdeps/unix 
-I../sysdeps/posix -I../sysdeps/i386/i586 -I../sysdeps/i386/i486 
-I../sysdeps/i386/fpu -I../sysdeps/i386 -I../sysdeps/wordsize-32 
-I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64 
-I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754 -I../sysdeps/generic/elf 
-I../sysdeps/generic  -nostdinc -isystem 
/usr/lib/gcc-lib/i386-redhat-linux/2.96/include -isystem /usr/src/linux/include 
-D_LIBC_REENTRANT -include ../include/libc-symbols.h     -o test-tgmath.o
In file included from test-tgmath.c:139:
test-tgmath.c: In function `compile_test':
test-tgmath.c:221: warning: implicit declaration of function 
test-tgmath.c:221: parse error before `__tgmres'
test-tgmath.c:221: parse error before `__tgmres'

showed up. This appears to be the same as Gnatsweb problem report #2925.

I then upgraded to Red Hat's gcc-2.96-85, which fixed the previous
problem. [So, Red Hat users should use gcc-2.96-85 or later, gcc-2.96-54 will
fail at make check. I don't know if gcc-2.96-69 will work or not.]

Now the only problem I have is:

make check

gcc -nostdlib -nostartfiles -o test-float  
-Wl,-dynamic-linker=/lib/ld-linux.so.2    ../csu/crt1.o ../csu/crti.o `gcc 
--print-file-name=crtbegin.o` test-float.o libm.so.6  
 ../libc.so.6 ../libc_nonshared.a -lgcc `gcc --print-file-name=crtend.o` 
GCONV_PATH=../iconvdata LC_ALL=C   ../elf/ld-linux.so.2 --library-path 
./test-float  > test-float.out
make[1]: *** [test-float.out] Error 1


testing float (without inline functions)
Failure: Test: yn (3, 10.0) == -0.25136265718383732978
 is:         -2.48292386531829833984e-01  -0x1.fc80b800000000000000p-3
 should be:  -2.51362651586532592773e-01  -0x1.01653600000000000000p-2
 difference:  3.07026505470275878906e-03   0x1.926d0000000000000000p-9
 ulp       :  103021.0000
 max.ulp   :  1.0000
Failure: Test: yn (10, 10.0) == -0.35981415218340272205
 is:         -3.55780839920043945312e-01  -0x1.6c51d000000000000000p-2
 should be:  -3.59814167022705078125e-01  -0x1.70732000000000000000p-2
 difference:  4.03332710266113281250e-03   0x1.08540000000000000000p-8
 ulp       :  135336.0000
 max.ulp   :  1.0000
Maximal error of `yn'
 is      : 135336 ulp
 accepted: 3 ulp

Test suite completed:
  2484 test cases plus 2280 tests for exception flags executed.
  3 errors occurred.

But, I _think_ this may be acceptable.

 Thank you,
 Mike Shell

reply via email to

[Prev in Thread] Current Thread [Next in Thread]