[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

solved: bug in strtoull

From: Manfred Weihs
Subject: solved: bug in strtoull
Date: Tue, 30 Apr 2002 10:00:49 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

I found the solution to the bug, I submitted yesterday.
I accidently did not include <stdlib.h>. Therefore gcc obviously used
some "internal" version of strtoull (that obviously is buggy), but did
not complain.

Manfred Weihs

-------- Original Message --------
Subject: bug in strtoull
Date: Mon, 29 Apr 2002 10:59:58 +0200
From: Manfred Weihs <address@hidden>
Organization: ICT, TU Wien
To: address@hidden

I use glibc 2.2.4 (on a RedHat 7.2 system) and I have a problem using
the strtoull function. It does not convert the string correctly. If I
try to convert "0x1122334455", I will get 0x000022334455. If I try to
convert "0xaabbccddee", I will get 0xFFFFFFFFBBCCDDEE. So it seems that
only the lower 4 bytes are correctly converted, wheras the higher 4
bytes contain nonsense.

Manfred Weihs

reply via email to

[Prev in Thread] Current Thread [Next in Thread]