[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

how do I install glibc-2.3.2 on older linux? (was: reldep3 test in glibc

From: John Lumby
Subject: how do I install glibc-2.3.2 on older linux? (was: reldep3 test in glibc-2.3.2)
Date: Mon, 06 Oct 2003 23:29:35 -0400

Firstly, Weston, thanks for your tip - which worked for me too. Actually I downloaded and compiled gcc 3.3.1 (using gcc 3.3) and then recompiled binutils again, and then recompiled glibc-2.3.2 - and no errors in make check.

Secondly, this brings me back to my original problem - how do I install this glibc? I'm on RedHat 7.3 (not badly hacked) with glibc-2.2.5. As I asked in
I don't see any way of installing this that will work satisfactorily and won't destroy my system. I didn't try configuring with --prefix=/usr because that (according to the install notes) would overwrite my existing system and make it unusable. I tried --prefix=/usr/local and refer to the above earlier posting of mine for what happened with that. I compiled it with --prefix=/usr/local/glibc2 which builds it beautifully but how do I now use it? I tried the instructions in the HOWTO :
chapter 4. Installing as a test library
but that doesn't work - after removing and recreating the link of /lib/ld-linux.so.2 nothing works - messages about unable to load libtermcap.so.2.

By inspecting the way that the programs which run as part of make check are compiled and run, I worked out the following way of compiling an application to use the new glibc-2.3.2 but it seems really awkward: gcc -nostdlib -nostartfiles -o hello -Wl,-dynamic-linker=/usr/local/glibc2/lib/ld-linux.so.2 -Wl,-z,combreloc /usr/src/glibc-build/csu/crt1.o /usr/src/glibc-build/csu/crti.o /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/crtbegin.o hello.c -Wl,-rpath=/usr/src/glibc-build:/usr/src/glibc-build/math:/usr/src/glibc-build/elf:/usr/src/glibc-build/dlfcn:/usr/src/glibc-build/nss:/usr/src/glibc-build/nis:/usr/src/glibc-build/rt:/usr/src/glibc-build/resolv:/usr/src/glibc-build/crypt:/usr/src/glibc-build/linuxthreads /usr/src/glibc-build/libc.so.6 /usr/src/glibc-build/libc_nonshared.a -lgcc /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/crtend.o /usr/src/glibc-build/csu/crtn.o && ./hello
hello world!

Weston - you are on RedHat 7.0 - how did you install your glibc-2.3.2? Or anyone? (who has installed from source)? There must be a way ... Please state your configure options and any steps you took after make install (if any). THANKS.

Original Message Follows----
From: Weston Markham <address@hidden>
To: "'address@hidden'" <address@hidden>
CC: "'address@hidden'" <address@hidden>, "'address@hidden'" <address@hidden>
Subject: reldep3 test in glibc-2.3.2
Date: Mon, 29 Sep 2003 22:21:23 -0400

I recently built glibc-2.3.2 on a linux machine (a hacked-up RedHat 7.0)
with a newly-built gcc 3.3.1 and binutils 2.14, and the elf/reldep3 test
failed with 'variable "some_var" not reset.  A couple of people have posted
this same problem on the bugs list, so I would like to share some additional
information:  I recompiled binutils and gcc with the new gcc, then rebuilt
glibc.  After that, the glibc build passes all its tests.  It is possible
that I also changed something else, and forgot about it, but I suspect that
I was working with a funny build of either gcc or binutils.


MSN 8 helps eliminate e-mail viruses. Get 2 months FREE*. http://join.msn.com/?page=features/virus

reply via email to

[Prev in Thread] Current Thread [Next in Thread]