[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: how do I install glibc-2.3.2 on older linux? (was: reldep3 te st in

From: Weston Markham
Subject: RE: how do I install glibc-2.3.2 on older linux? (was: reldep3 te st in glibc-2.3.2)
Date: Tue, 7 Oct 2003 20:29:47 -0400

Well, I'm not sure if I can recommend for people to follow in my footsteps,
necessarily.  But for what it's worth, I found that "configure
--prefix=/usr" worked for me.  More or less.  The native language support
routines appear to not recognize any locales, so I assume that either they
were not installed correctly, or I have old files that are confusing
something.  So far, that has merely annoying for me.  I believe that all my
existing binaries that linked to libc.so.6 (the one that RedHat 7.0 came
with) are now resolving to the new version.  The old version has been moved
(or was it always there, with links set up?) to a name with major and minor
version #'s in it.

Before I ran the "make install", I actually used a chroot jail to test the
new library.  There's an environment variable (install_prefix ?) that can
switch the install location at the time that you run "make install".  I set
up a fairly minimal copy of /bin, /lib, /etc, /usr/bin, /usr/lib, and a few
other things; and installed within there.  Then I did something like "chroot
jail sh", which gave me a command shell that was inside the jail.  I checked
that the installation seemed okay within the jail.  You should even be able
(if you put copies of all the right stuff) to verify that your compiler
works properly.  After I was minimally satisfied that this configuration
could work, I ran the install for real.

If you have a backup of the system, and are confident that you can restore
everything if something goes wrong, you might want to just try installing it
and seeing what happens.

Since installing glibc-2.3.2, I have run into the above-mentioned NLS
problem, but also:  I am currently unable to build g++ and gij from gcc such
that they pass "make check".  I have no idea at this point where to lay the
blame.  (I have continued to replace various system binaries.)  binutils,
gcc, and glibc are the usual suspects.

Anyway, good luck with whatever you try!

Weston Markham

-----Original Message-----
From: John Lumby [mailto:address@hidden
Sent: Monday, October 06, 2003 23:30
To: address@hidden
Cc: address@hidden; address@hidden;
Subject: how do I install glibc-2.3.2 on older linux? (was: reldep3 test
in glibc-2.3.2)

Firstly, Weston, thanks for your tip - which worked for me too.   Actually I

downloaded and compiled gcc 3.3.1 (using gcc 3.3) and then recompiled 
binutils again, and then recompiled glibc-2.3.2 - and no errors in make 

Secondly, this brings me back to my original problem - how do I install this

glibc?   I'm on RedHat 7.3 (not badly hacked) with glibc-2.2.5.     As I 
asked in
I don't see any way of installing this that will work satisfactorily and 
won't destroy my system.    I didn't try configuring with --prefix=/usr 
because that (according to the install notes) would overwrite my existing 
system and make it unusable.   I tried --prefix=/usr/local and refer to the 
above earlier posting of mine for what happened with that.     I compiled it

with --prefix=/usr/local/glibc2 which builds it beautifully but how do I now

use it?     I tried the instructions in the HOWTO :
chapter 4. Installing as a test library
but that doesn't work - after removing and recreating the link of 
/lib/ld-linux.so.2 nothing works - messages about unable to load 

By inspecting the way that the programs which run as part of make check are 
compiled and run, I worked out the following way of compiling an application

to use the new glibc-2.3.2 but it seems really awkward:
gcc -nostdlib -nostartfiles -o hello 
-Wl,-dynamic-linker=/usr/local/glibc2/lib/ld-linux.so.2 -Wl,-z,combreloc 
/usr/src/glibc-build/csu/crt1.o /usr/src/glibc-build/csu/crti.o 
/usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/crtbegin.o hello.c 
/usr/src/glibc-build/libc.so.6 /usr/src/glibc-build/libc_nonshared.a -lgcc 
/usr/src/glibc-build/csu/crtn.o && ./hello
hello world!

Weston - you are on RedHat 7.0 - how did you install your glibc-2.3.2?    Or

anyone?  (who has installed from source)?       There must be a way ...

  Please state your configure options and any steps you took after make 
install (if any).         THANKS.

Original Message Follows----
From: Weston Markham <address@hidden>
To: "'address@hidden'" <address@hidden>
CC: "'address@hidden'" <address@hidden>, "'address@hidden'" 
Subject: reldep3 test in glibc-2.3.2
Date: Mon, 29 Sep 2003 22:21:23 -0400

I recently built glibc-2.3.2 on a linux machine (a hacked-up RedHat 7.0)
with a newly-built gcc 3.3.1 and binutils 2.14, and the elf/reldep3 test
failed with 'variable "some_var" not reset.  A couple of people have posted
this same problem on the bugs list, so I would like to share some additional
information:  I recompiled binutils and gcc with the new gcc, then rebuilt
glibc.  After that, the glibc build passes all its tests.  It is possible
that I also changed something else, and forgot about it, but I suspect that
I was working with a funny build of either gcc or binutils.


MSN 8 helps eliminate e-mail viruses. Get 2 months FREE*.  

reply via email to

[Prev in Thread] Current Thread [Next in Thread]