[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

glibc configuration trouble

From: Robert Trask
Subject: glibc configuration trouble
Date: Tue, 11 Nov 2003 16:35:50 -0800

I'm not sure this is a bug, suspect it's my lack of knowledge of how to use the configure utility. If this is not the right place to ask about this problem I'd be grateful if you could advise me where to post.
Here's the problem:
I grabbed glibc (2.2.2) and linuxthreads (2.2.2) from the website, unpacked them into a working dir, then:
./configure --enable-addons=linuxthreads
I get the following error message:
*** You should not compile the GNU libc without the `linuxthreads'
*** add-on.  Not using them risks being incompatible with the
*** libraries of other systems.  Consider getting the add-on and restarting
*** the configuration.
*** If you really mean to not use this add-on, run configure again
*** using the extra parameter `--disable-sanity-checks'.
I've tried several variations of the configure command, all with the same result. What am I missing?
At this point I'm assuming that the message is advisory only, i.e. the glibc should build - with reservations.
If I then try to build I get:
xl-sj1-01{rtrask}84: make
Makeconfig:84: sysdeps/../config.make: No such file or directory
Makerules:598: no file name for `include'
The GNU C library has not been configured.
Run `configure' to configure it before building.
Try `configure --help' for more details.
make: *** [sysdeps/../config.status] Error 1
I've read through the README, INSTALL, and FAQ files. None give any indication I'm doing anything wrong.
What should I do to get this lib to build?

"That's not a muffin. Muffin is our cat."
-- Elizabeth

reply via email to

[Prev in Thread] Current Thread [Next in Thread]