[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

glbc installation error

From: Peng.P.Zhang
Subject: glbc installation error
Date: Fri, 14 Nov 2003 09:22:10 +0200


I cannot make sure if this is a bug but I cannot get hint from FAQ or INSTALL. 
The story is:

One our program compiled on Enterprise RH requires GLIBC-2.3.2  on RH8, so I 
tried to install glibc-2.3.2 on RH8 but failed. The compilation passed, the 
installation directory is /usr. (I am confused by FAQ items 2.3 and 2.36. Item 
2.3 suggests to install on /usr/local but item 2.36 suggests never install on 
/usr/local?) In details, I did

// make a separate directory glibc for compilation
mkdir glibc
cd glibc
../glibc-2.3.2/configure --prefix=/usr --enable-adds-on=linuxthreads
init 1
make install

Then, when I run "make install", an error saying "rm: relocation error: 
/lib/i686/libc.so.6 __libc_stack_end, version GLIBC_2.1 not defined in file 
ld-linux.so.2 with time reference" came out and crashed my laptop (intel). I 
did this as a single-user mode as suggested by FAQ. 

The previous gcc version on RH8 is gcc 3.2 and there are some libs and links 

/lib/libc.so.6 -> libc-2.2.93
/lib/i686/libc.so.6 -> libc-2.2.93
/lib/i686/libm.so.6 -> libm-2.2.93
/lib/i686/libpthread.so.0 -> libpthread-0.10.so
and empty in /usr/local/lib and /usr/local/include

Can anybody help me?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]