[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

__pthread_atfork@@GLIBC_2.0 not found !!

From: Ganesh C.N.
Subject: __pthread_atfork@@GLIBC_2.0 not found !!
Date: Wed, 31 Dec 2003 15:02:40 +0530

Hi ...

I have built a shared library using gcc 2.95.2 (with -lpthread option on) [glibc version: 2.1.3] and I am trying to run it on RHEL 3.0 [glibc version: 2.3.2].  I am facing the following problem while trying to load that shared library.

I get the following error :

symbol __pthread_atfork, version GLIBC_2.0 not defined in file libpthread.so.0 with link time reference.

I ran nm on my shared library and it shows __pthread_atfork as a weak symbol :
         w __pthread_atfork@@GLIBC_2.0

When I ran nm on the pthread library present in the RHEL 3.0 machine in which I trying to load, I get the following output :

00008250 t __pthread_atfork
00008250 t pthread_atfork
00008200 T address@hidden

i.e. __pthread_atfork@@GLIBC_2.0 is not defined in the target machine's libpthread. 

I searched on google and got the following link:
It says that the above problem seems to be a bug in RH9 and that there is a break in backward compatability.

Anybody has any idea how to resolve this problem ?  Any help is appreciated ....
Thanks in advance,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]