[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-glpk] internal error: row->lb != row->ub

From: Hermann Schwarting
Subject: [Bug-glpk] internal error: row->lb != row->ub
Date: Thu, 8 Nov 2007 17:42:15 +0300


I’m an Octave user. I have tried to implement the so called Earth 
Mover’s Distance, a difference measure for distributions. It is an 
optimization problem that maps to a transportation problem instance 
and can be solved by linear programming.

My script has worked well for many cases, but one particular
combination of inputs provokes an internal error in GLPK. I have 
exported the problematic case in CPLEX LP format and the command line 
version of glpk shows the same behaviour. The message is

$ glpsol --cpxlp test_glpk.lp
lpx_read_cpxlp: reading problem data from `test_glpk.lp'...
lpx_read_cpxlp: 208 rows, 9591 columns, 19182 non-zeros
lpx_read_cpxlp: 7264 lines were read
glp_simplex: original LP has 208 rows, 9591 columns, 19182 non-zeros
GLPK internal error: row->lb != row->ub; file glplpp02.c, line 1539

So I suspect the problem is not in Octave. Please see the attached 
test file. Is it an error on my side or a problem in glpk? I’d be 
grateful for advice.

My glpk version is 4.23 installed as binary packages from Debian 

(Please CC me, I’m not on the list.)

Attachment: test_glpk.lp.bz2
Description: BZip2 compressed data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]