[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-glpk] binary bug

From: Andrew Makhorin
Subject: Re: [Bug-glpk] binary bug
Date: Mon, 22 Dec 2008 08:37:34 +0300

> the following problem written in CPLEX format results in a binary
> error with the variable RutilScBin/RutilscL.
> Since glpk doesn't support semi-continuous variables I tried to simulate
> it - and got the described error. So where is the problem? By the way,
> CPLEX results in the same error but SCIP from ZIB (scip.zib.de) not! The
> variable RutilScBin is written to be zero but seems to be something like
> 0.000 ... 526547 (as I got from CPLEX) which destroyes the
> semi-continuity. Is there a workaround for this behaviour or better a
> patch?

Thank you for your report.

The error in the solution is caused due to "big M". In the solver
output sheet (at the bottom) you can find the ordinal number of a
violated constraint, which is 57, that corresponds to row RutilscU in
your cplex model:

RutilscU: Rutil - 1e6 RutilScBin <= 0

The constraint coefficient 1e6 is too big and leads to excessive
round-off errors.

Though glpk 4.34 finds correct solution to your model (as reported
in http://lists.gnu.org/archive/html/bug-glpk/2008-12/msg00007.html ),
it is just a happy chance. Currently the glpk mip solver is not smart
enough to recognize errors of such kind.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]