bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#51296: [PATCH] Add WebP format support


From: Eli Zaretskii
Subject: bug#51296: [PATCH] Add WebP format support
Date: Thu, 21 Oct 2021 11:19:44 +0300

> From: Stefan Kangas <stefan@marxist.se>
> Date: Wed, 20 Oct 2021 17:45:28 -0700
> Cc: 51296@debbugs.gnu.org
> 
> > Also fixed.
> 
> I spotted a typo, fixed in the attached patch.

Thanks, now only a few minor issues remain:

> +### mingw32 doesn't use -lwebp, since it loads the library dynamically.
> +HAVE_WEBP=no
> +if test "${with_webp}" != "no"; then
> +   if test "$opsys" = mingw32; then
> +      AC_CHECK_HEADER([webp/decode.h], [HAVE_WEBP=yes])
> +   elif test "${HAVE_X11}" = "yes" || test "${HAVE_W32}" = "yes" \
> +         || test "${HAVE_NS}" = "yes"; then
> +      WEBP_REQUIRED=0.6.0
> +      WEBP_MODULE="libwebp >= $WEBP_REQUIRED"
> +
> +      EMACS_CHECK_MODULES([WEBP], [$WEBP_MODULE])
> +      AC_SUBST(WEBP_CFLAGS)
> +      AC_SUBST(WEBP_LIBS)
> +
> +      if test $HAVE_WEBP = yes; then
> +        AC_DEFINE(HAVE_WEBP, 1, [Define to 1 if using libwebp.])
> +        CFLAGS="$CFLAGS $WEBP_CFLAGS"
> +      fi
> +   fi
> +fi

That's OK, but I believe you should also add WEBP to the list of Emacs
configuration features around line 5885 in configure.ac, so that WebP
support could be reported by system-configuration-features.

> +DEF_DLL_FN (int, WebPGetInfo, (const uint8_t* data, size_t data_size, int* 
> width, int* height));

Our style is to separate the '*' from the type, like this:

  DEF_DLL_FN (int, WebPGetInfo, (const uint8_t *, size_t, int *, int *));
                                              ^^             ^^     ^^
Also note that there's no need to use names of parameters in
prototypes, they just make the code longer, but don't add anything
useful.  So I removed them in the above.

> +static bool
> +init_webp_functions (void)
> +{
> +  HMODULE library;
> +
> +  if (!(library = w32_delayed_load (Qwebp)))
> +    return 0;
       ^^^^^^^^
"return false" is more consistent.

> +      contents = (uint8_t*) SSDATA (specified_data);

Space before '*' again.  Also, is the type cast really needed?  If
not, it is better to drop it.

> +  /* Validate the WebP image header.  */
> +  if (!WebPGetInfo (contents, size, NULL, NULL))
> +    {
> +      if (!NILP (specified_data))
> +     image_error ("Not a WebP file: `%s'", file);
> +      else
> +     image_error ("Invalid WebP data");

This last error message could IMO be more useful, if it said something
like "Non-WebP header in WebP image data".

> +     image_error ("Error when interpreting WebP data: `%s'", file);

Suggest to say "Error when interpreting WebP data from file `%s'"
instead, otherwise it may not be clear to the user what is that string
after the colon.

> +     image_error ("Error when interpreting WebP data");

I'd suggest "Error when interpreting WebP image data".





reply via email to

[Prev in Thread] Current Thread [Next in Thread]