[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PSPP-BUG: psppire crashes importing large text file

From: John Darrington
Subject: Re: PSPP-BUG: psppire crashes importing large text file
Date: Fri, 25 Apr 2008 10:08:47 +0800
User-agent: Mutt/1.5.13 (2006-08-11)

I tried this on my desktop.

On the first try, it crashed, as Jason described.  But all subsequent
attempts it worked fine.  Wierd!

I'm wondering if the problem might not be related to the large number
of warning messages rather than the text import itself.

Jason.  How about you run sed -i e 's/NA/0/g' temperature.txt and see
if that affects your experience?


On Thu, Apr 24, 2008 at 02:28:09PM -0700, Ben Pfaff wrote:
     Jason Stover <address@hidden> writes:
     > On Thu, Apr 24, 2008 at 04:57:28PM -0400, Jason Stover wrote:
     >> ...and still crashes on the desktop, right after pressing the final 
'Apply' button. 
     >> Here is a backtrace from the segfault:
     >> Program received signal SIGSEGV, Segmentation fault.
     >> 0x0808c3d7 in parse_field (ia=0xbfbdba08, row=<value optimized out>, 
column=5, outputp=0x0, tooltipp=0xbfbdc528)
     >>     at src/ui/gui/text-data-import-dialog.c:1690
     >> 1690      field = ia->separators.columns[column].contents[row];
     > Taking a closer look at this:
     > (gdb) p column
     > $16 = 5
     > (gdb) p *(ia->separators.columns + 5)
     > $17 = {name = 0x0, width = 3080471850, contents = 0xb79d1710}
     > So it looks like the name of the sixth column is null. And then:
     > (gdb) p *((ia->separators.columns + 5)->contents)
     > $19 = {string = 0x375e0 <Address 0x375e0 out of bounds>, length = 
     > I guess this is where it goes kablooie. I'm not sure why the address is 
     > of bounds.
     I encountered what must be the same bug while I was developing
     the text import implementation.  I didn't run into it toward the
     end of development and so I was kind of hoping it had just
     disappeared during code cleanup.  I see that I was wrong ;-(
     I'll try to debug this tonight, if I get a few minutes.
     "It was then I realized how dire my medical situation was.  Here I was,
      a network admin, unable to leave, and here was someone with a broken
      network.  And they didn't ask me to fix it.  They didn't even try to
      casually pry a hint out of me." --Ryan Tucker in the Monastery
     Bug-gnu-pspp mailing list

PGP Public key ID: 1024D/2DE827B3 
fingerprint = 8797 A26D 0854 2EAB 0285  A290 8A67 719C 2DE8 27B3
See http://pgp.mit.edu or any PGP keyserver for public key.

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]