[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PSPP-BUG: PSPP - bugs

From: Ben Pfaff
Subject: Re: PSPP-BUG: PSPP - bugs
Date: Wed, 01 Jul 2009 15:41:31 -0700
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.3 (gnu/linux)

Thank you for the bug reports.

Mike Griffiths <address@hidden> writes:

> I tried it out and found the following, which appear to be problems,
> particularly item 3.  Possibly some of the other items serve me right for
> using Windows...?

It definitely overstates the case to say that it "serves [you]
right", but the truth is that none of the main PSPP developers
use Windows as their primary development platform, so quality of
the Windows port tends to lag behind other platforms.

> 1.  I tried to enter some data in Data View and found I could not do so
> without first giving the variables names in Variable View - unlike SPSS, which
> gives default names.

This is a worthwhile feature request, I guess.  I filed a
"wishlist" bug, with you CC'd, in the PSPP bug tracker, at:

> 2.  I tried to name two variables, a and b, but when I entered a as the name
> of the first variable the programme did not recognise it the first time and
> said that the variable name could not be an empty string. 

I tried to reproduce this on GNU/Linux, with the version of PSPP
currently under development, and it worked fine for me.  It is
possible that this bug has been fixed since 0.6.1 was released,
or that it is Windows-specific.

> 3.  I entered the following (admittedly nonesense) data and called up a
> paired-samples t-test.  PSPP gave the correct value of t (1.00) but for the
> p-value gave 1.577, which is bigger not only than the correct figure but than
> the maximum theoretically possible p-value (which is 1).  (A little
> experimenting with other paired-samples tests suggests that the programme is
> reporting 2-p, where p is the correct value.)
> a    b
> 11  2
> 1   1
> 1   1

I'm sorry to hear that.  I don't see a change since 0.6.1 that
would have changed T-TEST's behavior, nor do I see a bug filed
for this already, so I filed a new bug with this information,
with you CC'd, at:
> 4.  I tried to remove the above figures to try something different, and the
> 'delete' button on my keyboard was inactive.

Hmm, I'm not sure exactly what you tried or expected.  When I
click on a cell in the data editor and push Delete, it changes
the cell to a missing value.  I'll readily admit that Deleting
cases and variables in the data editor is harder and less
intuitive than it should be.  I'm not going to bother to filing a
bug on that because it's obvious to me every time I try to enter
data :-)

> 5.  I tried to paste some figures in from Exel (a 2x8 table), but the figures
> all appeared in one cell of PSPP with blanks between them.

I think that this will take some help from a Windows developer.
We don't have any right now, so filing a bug is probably not
going to get any response.  You could do so yourself if you like,

> 6.  I tried to undo the above paste, but found no 'undo' in the Edit manual,
> and I couldn't undo with Control-Z either.

I agree that an undo function would be useful.  There is a bug
filed about this already:
"Writing is easy.
 All you do is sit in front of a typewriter and open a vein."
--Walter Smith

reply via email to

[Prev in Thread] Current Thread [Next in Thread]