[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

PSPP-BUG: pspp-0.8.1 : Problem with image resources and with opening .sa

From: Thierry Maillard
Subject: PSPP-BUG: pspp-0.8.1 : Problem with image resources and with opening .sav data
Date: Sat, 28 Dec 2013 16:32:20 +0100

Hello Jeremy Lavergne

First, thank you for porting GNU pspp software on Mac.

I met two problems with pspp version 0.8.1 I've just downloaded on your web site
<http://lavergne.gotdns.org/projects/pspp> :

The 2 problems happen on two of my Macs :
-  An MacMini Intel Core 2 Duo with Mac OS X 10.6.8 (Snow Leopard) ;
- A MacBook Pro with Mac OS X 10.9 (Mavericks)
I launched pspp with the admin account on which I installed pspp or with an non dmin account.

First problem (non blocking), I solved thanks to an advice displayed in Console App :
- All graphics resources (small icons of your software are not found)
Command to solve problem
/opt/pspp/bin/gdk-pixbuf-query-loaders > /opt/pspp/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache

Message in console :
28/12/13 15:27:15 [0x0-0x2b02b].org.gnu.software.pspp.PSPP[348] (PSPP:348): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/opt/pspp/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory
28/12/13 15:27:15 [0x0-0x2b02b].org.gnu.software.pspp.PSPP[348] This likely means that your installation is broken.
28/12/13 15:27:15 [0x0-0x2b02b].org.gnu.software.pspp.PSPP[348] Try running the command
28/12/13 15:27:15 [0x0-0x2b02b].org.gnu.software.pspp.PSPP[348]  gdk-pixbuf-query-loaders > /opt/pspp/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
28/12/13 15:27:15 [0x0-0x2b02b].org.gnu.software.pspp.PSPP[348] to make things work again for the time being.
28/12/13 15:27:16 [0x0-0x2b02b].org.gnu.software.pspp.PSPP[348] (PSPP:348): Gtk-WARNING **: Erreur de chargement de l'ic?ne?: Impossible de reconna?tre le format d'image du fichier ??/opt/pspp/share/pspp/actions/24x24/file-open-document.png??

Second problem (blocking) :
In psppire GUI, I can't open any .sav file : those just saved with pspp or those found in example directory
No .sav file are displayed in pspp file chooser (See attached screenshot)

According to you, why aren't .sav files shown in pspp file Chooser.

I tried to launch pspp with dtruss utility 
sudo dtruss -f sudo -u $USER /opt/pspp/bin/psppire

A message explains that pspp do a succesfull lstat64() on an existing .sav file,
success in openning the .sav, read it : read(0x12, "\0", 0x0) and close it.

Have you got an explanation or a solution for those problems ?

Best regards
Thierry Maillard - address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]