[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PSPP-BUG: Building PSPP 0.8.2 under fedora 19

From: John Darrington
Subject: Re: PSPP-BUG: Building PSPP 0.8.2 under fedora 19
Date: Fri, 28 Mar 2014 14:48:44 +0100
User-agent: Mutt/1.5.21 (2010-09-15)

On Fri, Mar 28, 2014 at 01:47:18PM +0100, Alexander Hepp wrote:
     Dear PSPP team,
     first of all, let me thank you for offering such a great tool under GNU 

You are welcome.
     Let me state, that I am not a Linux expert. 

For the record, PSPP has nothing to do with Linux, except that Linux is just one
kernel that is often used in the operating systems upon which many people choose
to run PSPP.

     Now, the issue is, that our internal hosting provider as switched their 
machines from Solaris to a i686 architecture (having RHEL) and we have no 
access to those machines to install pspp there directly. So we would have to 
provide a version precompiled for that machines. I have tried to have a Fedora 
VM on my machine (using vagrant), and I have pretty much everything configured 
as needed AFAIK (using yum install). All mentioned prerequisites are there.
     But the v0.8.2 will still not build.
     I am trying with the following configure:
     ./configure --without-gui --without-cairo --enable-relocatable 
     as we only need the .sav creation and no gui or graphs. The configure is 
working fine, but as soon as I run
     I get the following errors:
     src/output/ascii.c:154:21: error: field 'fg' has incomplete type
          struct xr_color fg;
     src/output/ascii.c:155:21: error: field 'bg' has incomplete type
          struct xr_color bg;
     src/output/ascii.c: In function 'ascii_create':
     src/output/ascii.c:265:3: warning: implicit declaration of function 
'parse_color' [-Wimplicit-function-declaration]
        parse_color (d, o, "background-color", "#FFFFFFFFFFFF", &a->bg);
     Do you have any idea on what I could do to make it build successfully?

This was an oversight in 0.8.2 which manifested itself when --without-cairo was 
It was reported and fixed a few weeks ago.   

You have three options:

1. Install cairo and don't use --without-cairo for configure.
2. Wait for 0.8.3 to be released ; OR
3. Download the snapshot release from 
By the way, you are unlikely to need --enable-relocatable it will only make 
operation slower.


PGP Public key ID: 1024D/2DE827B3 
fingerprint = 8797 A26D 0854 2EAB 0285  A290 8A67 719C 2DE8 27B3
See http://sks-keyservers.net or any PGP keyserver for public key.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]