[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

PSPP-BUG: Problem configuring on Slackware

From: Frans Houweling
Subject: PSPP-BUG: Problem configuring on Slackware
Date: Wed, 6 Jan 2016 19:48:09 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.5.0

   this is probably not a bug - I am just hoping for you to help me:
checking whether gcc -std=gnu99 accepts -fgnu89-inline... yes
checking whether <wchar.h> uses 'inline' correctly... no
configure: error: <wchar.h> cannot be used with this compiler (gcc -std=gnu99 -g -O2 -pthread -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/libdrm -I/usr/include/pango-1.0 ). This is a known interoperability problem of glibc <= 2.5 with gcc >= 4.3 in
C99 mode. You have four options:
  - Add the flag -fgnu89-inline to CC and reconfigure, or
  - Fix your include files, using parts of
<http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=b037a293a48718af30d706c2e18c929d0e69a621>, or
  - Use a gcc version older than 4.3, or
  - Don't use the flags -std=c99 or -std=gnu99.
Configuration aborted.

I tried the first option with no luck (same error) - the other ones are beyond my powers.
The reason for disturbing you is that my glibc version appears > 2.5
pspp-0.8.5$ ls /var/log/packages/ | grep glibc
spp-0.8.5$ ls /var/log/packages/ | grep gcc

Should I wait for Slackware 15?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]