[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: macosx linking fails: _freea referenced from: _rpl_realpath

From: Bruno Haible
Subject: Re: macosx linking fails: _freea referenced from: _rpl_realpath
Date: Tue, 25 Jun 2019 22:31:06 +0200
User-agent: KMail/5.1.3 (Linux/4.4.0-151-generic; KDE/5.18.0; x86_64; ; )

Sam Steingold wrote:
> I re-run gnulib-tool and it fixed it.
> (alas, emacs maintainers pushed the changes before me ;-)

So, what was the cause? What can be done to avoid similar errors in the future?

When I look at the history of emacs/lib/gnulib.mk.in, it looks like
(1) there was a change that added dependencies to canonicalize-lgpl and malloca
    yesterday, but it did NOT add the variable gl_GNULIB_ENABLED_malloca.
(2) Paul regenerated it again, which added the variable 

(1) apparently introduced the problem that Sam reported. (2) fixed it.

Daniel, do you have an idea why your tooling created an incomplete
emacs/lib/gnulib.mk.in, that you then checked in?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]