[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-gnupod] device is busy

From: wanded
Subject: [Bug-gnupod] device is busy
Date: 05 Oct 2003 13:12:37 +0100

Find attached my copy of GNUtunesDB and iTunesDB.

I have the following problem:

1. mount /mnt/ipod succesfully

2. add or delete a song using gnupod_addsong

3. type in the command mktunes.pl ($IPOD_MOUNTPOINT is defined, e.g.
echo $IPOD_MOUNTPOINT shows definition) or mktunes.pl -m /mnt/ipod 

4. when i try to unmount /mnt/ipod i get the following error message:
        umount: /mnt/ipod: device is busy

If I try to unmount it say 30 minutes later, I get the same message. Its
like a process has a handle to the directory. I'm guessing its
mktunes.pl with my version of the two databases.

I tried version 0.90 some time ago and it worked fine, adding songs,
deleting songs, mktunes and unmount was all fine. Then I recently
installed 0.91 added more songs, and got the error message 'device is
busy'. Then I re-installed 0.90 thinking it was a 0.91 bug. I get the
same message appear for both now.

I really like the perl scripts as a way of hooking up to the ipod. Check
out 'Rip' in the gnu project. Its a perl script project for ripping
cd's. I like it alot.

Can you help.

Many thanks.

Attachment: DBFiles.tar.gz
Description: GNU Zip compressed data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]