[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnupod] gnupod on Windows XP/7, install/configure/make issues

From: Brian Stewart
Subject: Re: [Bug-gnupod] gnupod on Windows XP/7, install/configure/make issues
Date: Wed, 6 Oct 2010 18:33:04 -0500


I do understand unix/linux/solaris file system concepts, etc -- but
it's not my native environment, so hopefully you won't have to spoon
feed me everything.

1. I actually do have a /usr/local/bin/  -- its just empty, which is
part of the problem.

2. $ echo $PATH
Files (x86)/NVIDIA
Corporation/PhysX/Common:%CommonProgramFiles%/Microsoft Shared/Windows
Files (x86)/Common Files/Roxio Shared/DLLShared/:/cygdrive/c/Program
Files (x86)/Common Files/Roxio
Shared/9.0/DLLShared/:/cygdrive/c/Program Files
(x86)/QuickTime/QTSystem/:/cygdrive/c/Program Files/Common
Files/Microsoft Shared/Windows Live

3. I tried (two ways)
./configure --prefix=/usr/local,
./configure --prefix=/cygdrive/e/gnu

make install (both tries)
but it is still throwing
> src/gnupod_addsong.pl --> //usr/local/bin/gnupod_addsong.pl
> src/gnupod_addsong.pl --> //cygdrive/e/gnu/bin/gnupod_addsong.pl

Note the double forward slashes //, which can't be right based on all
the other paths i've seen in the outputs.  the make install: did built
the /cygdrive/e/gnu/bin and share paths, but // is holding up the rest
of the script.   /cygdrive/e/gnu/  did not exist today until i tried
with your --prefix, so i know it had no problem making the structure.

4. I wonder why it finds Perl properly at /cygdrive/e/Perl/site/bin,
but then when generating the make file shows: Perl INC        :

On Wed, Oct 6, 2010 at 3:56 PM, H. Langos <address@hidden> wrote:
> Hi Brian,
> I havn't used cygwin in quite a while and I've never used it with
> GNUpod but I'll try to help anyway. :-)
> On Wed, Oct 06, 2010 at 02:07:57PM -0500, Brian Stewart wrote:
>> address@hidden /cygdrive/d/apps/gnupod/gnupod-0.99.8
>> $ ./configure
> Try
> ./configure --prefix=/cygdrive/e/someplace
> instead.
> That should help.
> ...
>> Settings:
>> ---------
>> Release         : 0.99.8
>> Perl Version    : 5.8.9
>> Prefix          : /usr/local
>> Perl INC        : E:/Perl/site/lib
>> Encoders        : (mpeg4/no ffmpeg with aac support found) (disabled
>> faac: Binary not found) (disabled lame: Binary not found) wav
>> Decoders        : (disabled timidity: Binary not found) (disabled
>> flac: Binary not found) (disabled oggdec: Binary not found)
>> Artwork Support : Yes
>> -> use 'make install' to install GNUpod
>> -> use 'info GNUpod' to read the documentation after you installed GNUpod
>> -> use 'make uninstall' to remove GNUpod from /usr/local
>> But when i run make install, it pukes based on some kind of pathing
>> issue --- assuming Win32 translation error of some sort.
> Well, it tries to install into /usr/local/... while in cygwin you seem to
> have to use something like /cygdrive/<driveletter>/<path>
> So if you wanted it to install into C:\Programms\foo you'd have to use
> something like /cygdrive/c/Programms/foo
> In general unix systems don't use drive letters. Different "drives" all are
> mapped (or "mounted" in unix-speak) into one directory tree that starts
> with it's root "/". So while your home directory in /home/brian may be on
> the first hard drive and a cdrom may be mounted under /media/cdrom they
> are both accessible in the same directory tree.
> The other big difference is that unix systems usually don't separate
> program from program by installing them into different directories
> like windows does. E.g. There is C:\Program Files\foobar2000 and
> C:\Program Files\winamp. In those directories the programs, their .ini
> files, their data files and their log files lie.
> While in a unix system programs go to /usr/bin , configuration files go
> to /etc, and log files go to /var/log. And so on...
> These are just the most basic differences. There's much more that cygwin
> tries to mend and reconcile.
> If you want gnupod scripts to be executable from the cygwin shell, you'll
> have to find out where cygwin will look for executables.
> Try entering "echo $PATH" in the shell and it should give you a
> ":"-separated list of directories and an idea what your prefix for
> ./configure should be set to.
>> Could not write //usr/local/bin/gnupod_addsong.pl: No such file or directory
>> Installing GNUpod 0.99.8 using gnupod_install 0.25
>>  > src/gnupod_addsong.pl --> //usr/local/bin/gnupod_addsong.pl
>> make: *** [install] Error 2
>> Would love to get this running, any guidance from someone with cygwin
>> experience would be great.   I attempted several hacks on the make
>> routine to get past it but no go.
> Let's see what "echo $PATH" spits out and I guess we can get it to work.
>> At the moment, I am running the .pl gnupod commands directly from
>> ActiveState Perl (outside of the *NIX cygwin) environment. Using the
>> gnupodrc control file has been a life-saver in my hammering. I've
>> managed to make it suck in my itunesDB from the ipod and rewrite it
>> back out, all without hosing my ipod.
> Good to hear that :-)
> cheers
> -henrik

reply via email to

[Prev in Thread] Current Thread [Next in Thread]