[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-gnupod] Re: gnupod on Windows XP/7, install/configure/make issues

From: Brian Stewart
Subject: [Bug-gnupod] Re: gnupod on Windows XP/7, install/configure/make issues
Date: Fri, 8 Oct 2010 14:44:52 -0500


> Notice the "config.status: WARNING:  'Makefile.in' seems to ignore the
> --datarootdir setting" message not sure if that has any impact.  I've
> tried your --prefix in numerous ways to no avail.

>Does configure ignore "--prefix=foo" or does it produce an error message?

address@hidden ~/gnu
$ ./configure --prefix=foo
configure: error: expected an absolute directory name for --prefix: foo

so then i tried

address@hidden ~/gnu
$ ./configure --prefix=/foo

Same results during the make:

address@hidden ~/gnu
$ make install
/bin/sh ./mkinstalldirs /foo/bin
mkdir -p -- /foo/bin
/bin/sh ./mkinstalldirs /foo/share/man/man1
mkdir -p -- /foo/share/man/man1
/cygdrive/c/strawberry/perl/bin/perl tools/gnupod_install.pl INSTALL
"/cygdrive/c/strawberry/perl/bin/perl" "/foo/bin" "/foo/share/info"
"/foo/share/man" ""
Could not write //foo/bin/gnupod_addsong.pl: No such file or directory
Installing GNUpod 0.99.8 using gnupod_install 0.25
 > src/gnupod_addsong.pl --> //foo/bin/gnupod_addsong.pl
make: *** [install] Error 2


I will try and edit the Makefile, and your other suggestions.


Correct me if I am wrong, but gnupod is basically pure Perl with .pm
modules -- technically if i can get all the files setup, and environ.
variables defined (which are probably be stuffed into the *nix
.profile) it should just work -- or are there some non-Perl calls
being made that truly rely on *nix?

Thanks for your time.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]