[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug-gv] gv gives gs error when reloading or scaling

From: Daniel Allcock
Subject: [bug-gv] gv gives gs error when reloading or scaling
Date: Mon, 10 Jul 2006 10:58:46 -0500
User-agent: Thunderbird (X11/20060615)

First, I'd like to say thanks for maintaining the great gv package.
I use it for all my pdf and ps viewing because I like the spartan
interface so much better than the bloat in other viewers.
So, thanks!

Here is my bug. I installed gv 3.6.1 as part of Kubuntu 6.0.6 (Dapper Drake); my gs is esp-gs version 8.15.2. When using gv on a pdf file, it opens fine and I can page forward and back in my document, but if I hit + or = to rescale, or if I click the reload button, then it often refuses to display anything, and pops up a gs-errors box. Here is an example:

ERROR: /invalidfileaccess in --file--
Operand stack:
   (/home/allcock/research/3foldch10/threefolds9.pdf)   (r)
Execution stack:
%interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 1 3 %oparray_pop 1 3 %oparray_pop 1 3 %oparray_pop 1 3 %oparray_pop .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval--
Dictionary stack:
--dict:1122/1686(ro)(G)-- --dict:0/20(G)-- --dict:85/200(L)-- --dict:104/127(ro)(G)-- --dict:241/347(G)--
Current allocation mode is local
ESP Ghostscript 815.02: Unrecoverable error, exit code 1

I can't even rescale to the original magnification; once it's wedged then it seems to be really wedged. If I try then it just appends more gs errors to the error log.

Strangely, this doesn't happen all the time. It seems to happen reliably when I use the command line from a directory not containing the file, and not above the file in the directory hierarchy. When I click on a file to view in konqueror then it always opens up fine, but then reliably fails with an error similar to the above when I try to reload or use - or =.

Finally, I the problem doesn't seem to happen when viewing ps. So perhaps the problem is something to do with conversion or temporary files?

Here are some things I've already tried:
1. I installed gnu-gs, thinking perhaps there could     
        be some sort of version mismatch, and used update-alternatives
        to change which gs gets used.  No change.
2. I downloaded the gv tarball from gnu's website and compiled from
        source, thinking that maybe there was a kubuntu configuration
        error.  Changed into the src dir and ran ./gv.  No change.
3. I tried both doing both of these simultaneously.  No change
4. I have read all the documentation on gv I could find, looking for
        some sort of flag or setting that might be relevant.  No luck.
5. I've looked through many web forums, google, etc., looking for record
        of others having this bug too.  No luck.  Very strange, since
        my kubuntu system is newly installed, so you'd think everyone
        would have the same problem.

I'd appreciate your help with this since I use gv many times a day!
Of course, I'll be happy to give you more info and try things out.

Daniel Allcock

reply via email to

[Prev in Thread] Current Thread [Next in Thread]