[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: hello-2.1.91 modernization

From: Bruno Haible
Subject: Re: hello-2.1.91 modernization
Date: Tue, 22 Aug 2006 22:35:27 +0200
User-agent: KMail/1.9.1

Paul Eggert wrote:
> I prefer "#if HAVE_FOO", as it's easier to read, and I'd rather not
> convert everything in sight to "#ifdef HAVE_FOO".

Likewise for me. There are cases when a HAVE_FOO macro needs to be
defined to 0 in the negative case (for example, if we want to use it
as an expression inside a function). I would prefer not to have to go
back to a state where I have to think about each #if: "should I write
#if or #ifdef here?"


reply via email to

[Prev in Thread] Current Thread [Next in Thread]