[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: m4-1.4q on Tru64Unix

From: Gary V. Vaughan
Subject: Re: m4-1.4q on Tru64Unix
Date: Tue, 14 Oct 2003 12:59:18 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925 Thunderbird/0.3

Martin MOKREJŠ wrote:
On Fri, 10 Oct 2003, Gary V. Vaughan wrote:

That will stop the SEGV, but I fear there is something deeper going wrong, as
one of the handles must have a null name.

If you can give me SSH access to your machine I'll be able to help you debug 

How about http://testdrive.hp.com/systems/alpha.shtml

Well, I signed up for an account, transferred the m4 sources to one of the alpha ev7's, and the build chokes on perl.c with the `cannot specify -o with -c or -S and multiple compilations' error you reported last week :-( I think this is some problem with gcc vs DEC ld...

Next, I tried `configure CC=cc', and the build completed, and the testsuite showed the same test failures you reported, but in the testsuite.log I get `libiconv has no entry points'. No SEGV, no core dump. Bah! :-(

Finally, I tried `configure CC=cc --disable-nls', but despite the lack of internationalisation, I still get iconv errors in the logs. :'(

What configure and compiler options did you use to generate the SEGV? I can't find a way to reproduce it...

  ())_.  Gary V. Vaughan    gary@(lilith.warpmail.net|gnu.org)
  ( '/   Research Scientist http://www.oranda.demon.co.uk       ,_())____
  / )=   GNU Hacker         http://www.gnu.org/software/libtool  \'      `&
`(_~)_   Tech' Author       http://sources.redhat.com/autobook   =`---d__/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]