[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: any reason not to enforce the build requirement: m4 >= 1.4.4 ?

From: Eric Blake
Subject: Re: any reason not to enforce the build requirement: m4 >= 1.4.4 ?
Date: Thu, 01 Feb 2007 13:02:55 -0700
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20061207 Thunderbird/ Mnenhy/

Hash: SHA1

According to Jim Meyering on 2/1/2007 9:37 AM:
> I spent some time recently tracking down a bug that arose from an autoconf
> installation built using m4-1.4.2.  My testing showed that autoconf built
> using any version of m4 older than 1.4.4 would have the same problem.

What bug was it?

> I'm sure it would save others from spending the time to track down this
> sort of problem, if there were a configure-time or build-time check for a
> working version of m4.  However, when I last checked (a week or two ago)
> there was none.
> I can't be the first to suggest this.
> Is there some reason not to require that we're
> using a working version of m4 when building?
> I think I can cook up a (mis)feature test.

If nothing else, I've already cooked up a (mis)feature test for detecting
the tracing bug in 1.4.4 and earlier that affected bootstrapping m4 itself
using MacOS's default 1.4.2 vs. automake 1.10:


Maybe it is time to bite the bullet and modify that test into autoconf's
m4/m4.m4 so that autoconf 2.62 has a hard requirement on m4 1.4.5 or newer?

- --
Don't work too hard, make some time for fun as well!

Eric Blake             address@hidden
Version: GnuPG v1.4.5 (Cygwin)
Comment: Public key at home.comcast.net/~ericblake/eblake.gpg
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


reply via email to

[Prev in Thread] Current Thread [Next in Thread]