[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: snapshot in preparation for 1.4.13

From: Elbert_Gmail
Subject: Re: snapshot in preparation for 1.4.13
Date: Sun, 18 Jan 2009 11:27:32 +0100
User-agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.1b1pre) Gecko/20081008000000 SeaMonkey/2.0a1

Eric Blake wrote:
Hash: SHA1

According to Elbert_Gmail on 12/25/2008 1:21 AM:
I try again with Os2 and the ./configure failed here:
checking whether an open file can be renamed... return: Illegal
number: -/
Thanks for the report.  However, we need more information; can you also
attach the config.log?

I attach the config.log

[adding bug-autoconf, because of the shell bug shown here]

| configure:23375: checking whether an open file can be renamed
| configure:23397: gcc -std=gnu99 -o conftest.exe -D__EMX__ -DOS2
- -D__ST_MT_ERRNO__ -O3 -mtune=pentium3  -Zexe -Zomf -Zmap -Zargs-wild
- -Zbin-files -D__ST_MT_ERRNO__ -s conftest.c>&5
| configure:23397: $? = 0
| configure:23397: ./conftest.exe
| configure:23397: $? = -/
| configure: program exited with status -/

Wow.  Your shell is buggy.  $? is never supposed to hold a non-numeric
value.  Your config.log shows that you loaded a config.site, where you
pre-define SHELL=sh and ac_cv_path__PATH_SH='/moztools/ash.exe, so maybe
it just means you have a broken ash installed?  Does OS/2 even come with a
default pre-built bourne-style shell, or is ash something you built
yourself?  Can you upgrade to a better shell?

At any rate, your platform seems more and more like a lost cause.  The
fact that configure doesn't even complete means that autoconf-generated
scripts are not portable to your platform; we would have to fix that
first, but we can't even write an autoconf patch to work around corruption
in $? unless you can find a workaround.  Meanwhile, since you obviously
can't rename an in-use file, you can get past this check by calling
'./configure M4_cv_func_rename_open_file_works=no'.

Ok, this runs ok now.
But after i run the make i get this:
m4.c: In function 'fault_handler':
m4.c:151: error: 'STDERR_FILENO' undeclared (first use in this function)
m4.c:151: error: (Each undeclared identifier is reported only once
m4.c:151: error: for each function it appears in.)
make.exe[2]: *** [m4.o] Error 1
make.exe[2]: Leaving directory `U:/m4-'
make.exe[1]: *** [all-recursive] Error 1
make.exe[1]: Leaving directory `U:/m4-'
make.exe: *** [all] Error 2

Sorry for being such a pain in the (*)
but it;s hard to get up to dated for a Os that nearly is dying but i try to keep along as much that is possible.
That means i run a lot in the back compare to other os!

- --
Don't work too hard, make some time for fun as well!

Eric Blake             address@hidden
Version: GnuPG v1.4.9 (Cygwin)
Comment: Public key at home.comcast.net/~ericblake/eblake.gpg
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


reply via email to

[Prev in Thread] Current Thread [Next in Thread]