[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-wget] WGet & ftps - can't get past "unsupported scheme"

From: Leonard Hampton
Subject: [Bug-wget] WGet & ftps - can't get past "unsupported scheme"
Date: Thu, 11 Mar 2010 17:47:40 -0500

I am attempting to use WGet on a windows 2003 server (running as a virtual
machine) to access and download the contents of a webdav directory.  The
site contains a set of n-level deep directories, and we are expected to
cache the entire structure on our server, periodically checking for updates.
I have tried about 3 dozen different combinations of WGet command-line
arguments, but simply can't seem to get past the:
   " <url>: unsupported scheme." error
We have used WGet in the past to download individual files from a similar
https site.  I started with version 1.10.?, but yesterday downloaded the
latest version I could find for windows: 1.11.4
Can someone please give me a clue as to what's wrong with this command line?
wget --user=*** --password=*** --no-host-directories -r -N -l 10
wget --user=*** --password=*** --no-host-directories -P C:/TestDir/FBD -r -N
-l 10 ftps://files-cert.organizationname.net/webdav/*
(In my final attempts, I removed the -P and destination folder trying to
simplify the command.)
the result is always: ftps://files-cert.organizationname.net/webdav/*:
Unsupported scheme.
I even tried escaping the - in the site name to %2d to no avail.
If I change the site name to start with https:, I get much further, but the
process failes for other reasons, and even per the WGet documentation, I
can't ask for *ALL FILES* in the path as I can with ftp.
Thanks much!
Leonard Hampton, 
Mountainside Software, Inc. 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]