[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] Can't build wget 1.12 on MSWindows XP

From: Keisial
Subject: Re: [Bug-wget] Can't build wget 1.12 on MSWindows XP
Date: Fri, 30 Apr 2010 16:30:00 +0200
User-agent: Thunderbird

Micah Cowan wrote:
> Vincent Belaïche wrote:
>> I tried to build unsuccessfully Wget on MSWindowsXP.
>> Attached to this email are the logs of this attempt.
>> I tried the ./configure+make way with MSYS+MinGw
>> When configuring I made a 1st attempt with only prefix and infodir
>> options, and then a 2nd attempt  where I tried to disable all that could
>> be disabled, in the hope that the build would be successful.
Your main problem is that WINDOWS macro isn't defined. Add -DWINDOWS=1
to the CFLAGS.

>> Are there any binary distribution of Wget for MSWindows?

There's http://gnuwin32.sourceforge.net/packages/wget.htm but it's at 1.11.4
I know they tried to update it, but I don't know about its status.

> Unfortunately, there isn't, and the official wget 1.12 release lacks
> some necessary changes to allow building with MSYS+MinGw. The current
> development sources in Mercurial should work, BUT I was never able to
> get openssl working properly with it, which means no HTTPS (encrypted
> web) support.
> Hopefully someone will bring Wget the rest of way before too long.

I'm pretty sure I was able to build wget with openssl from mercurial.
I don't think I ever followed the exact gnulib ./configure but once wget
the change to get openssl was minimal.
Of course, certificates never validate but that's an openssl issue. You
would need to copy locally the root certificates for them to work and make
openssl point there.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]