[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] wget creating file

From: Jochen Roderburg
Subject: Re: [Bug-wget] wget creating file
Date: Wed, 22 Dec 2010 09:57:31 +0100
User-agent: Internet Messaging Program (IMP) H3 (4.3.7)

Zitat von Micah Cowan <address@hidden>:

I suspect that he's just trying to post some data to the specified link,
which isn't expected to provide a real response, which is why he finds
the resulting "trigger" file useless. -O- > NUL (or perhaps just -O NUL)
ought to do the trick, once he's doing that.

Yes, of course, just -O NUL does it also, even simpler as the redirection.

I have the same result here with the latest binary from C.Lewis's site as well as with the gnuwin32 version:

c:\temp> wget -O nul http://www.uni-koeln.de/

--09:46:08--  http://www.uni-koeln.de/
           => `nul'
Resolving www.uni-koeln.de... done.
Connecting to www.uni-koeln.de[]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 11,145 [text/html]

100%[====================================>] 11,145 544.19K/s ETA 00:00

09:46:08 (544.19 KB/s) - `nul' saved [11145/11145]

The transferred remote file is correctly written to the local pseudo-file NUL and disappears in this "black hole".

I think, the OP just hasn't tried exactly what the people keep telling him here. ;)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]