[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] Bug report about WGet

From: Micah Cowan
Subject: Re: [Bug-wget] Bug report about WGet
Date: Wed, 02 May 2012 13:47:55 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20120410 Thunderbird/11.0.1

In both cases, your shell is transforming your arguments before wget
gets a chance to see it.

Don't percent-encode ampersands - they need to be literal ampersands in
order to maintain their function as separating key/value pairs.

Instead, be sure to wrap the URL in double quotes ("), to protect your
Windows command shell from interpreting some characters specially.


On 05/02/2012 06:14 AM, Vladimir wrote:
> Good day!
> At first sorry for mistakes because English is'nt my native language.
> I tried using WGet 1.9 and 1.11 (downloading variant for Windows) and found 
> one trouble in both versions.
> I need to retrieve URL, contained such symbol as "&". This URL is:
> http://cargo.rzd.ru/cargostation/public/cargo?STRUCTURE_ID=5101&layer_id=4829&refererLayerId=4821&id=1
> (This page is in Russian, don't pay attention on language.)
> But I can't encode this symbol. I tried to use construction "%26" instead of 
> "&":
> http://cargo.rzd.ru/cargostation/public/cargo?STRUCTURE_ID=5101%26layer_id=4829%26refererLayerId=4821%26id=1
> But WGet send it as:
> http://cargo.rzd.ru/cargostation/public/cargo?STRUCTURE_ID=51016layer_id=48296refererLayerId=48216id=1
> E.g. WGet decode "%2", not "%26"! Only first digit of hexadecimal 
> representation of the character's ascii value is using.
> I hope you will understand this description and fix this problem.
> Vladimir.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]