[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] Big refactoring

From: illusionoflife
Subject: Re: [Bug-wget] Big refactoring
Date: Wed, 08 Aug 2012 20:52:21 +0400
User-agent: KMail/4.9 (Linux/3.5.0-2-LIBRE; KDE/4.9.0; x86_64; ; )

On Tuesday, August 07, 2012 21:40:49 you wrote:
> I do agree with the general principal you're promoting, which is to
> replace oft-repeated bits of functionality with clearly-named functions
> that identify what they do. But I also think there are extremes to which
> it can be applied, and that this qualifies as an example.
Okay. It is one of the least problems. But I still want to hear other 
opinions. I got your preferences.

> What about it? I'm not understanding your question. You keep mentioning
> using list.h, but using WHAT list.h? Wget doesn't have a list.h, so
> whose list.h are you talking about? And why is it better than, say,
> using gnulib's "list" module (with gl_list.h, etc)?
Ah, sorry. http://isis.poly.edu/kulesh/stuff/src/klist/
Why it is better? To me, it gives more readability, than gl_list or GList,
Well, difference is between `struct foo {int a,b;}' and 
`struct foo{int a,b; struct foo *next,*prev;}'. 
I know, perfomance is irrelevant, but gl_list forces one more operator * 
usage :) 
Please, alloc you time to read list.h. Probably, you will agree with me, that 
it way more elegant.

Well, and little patch I made as start of big way.

Best regards, illusionoflife
Contact me on address@hidden
Please, read rfc1855, if did not already.

Attachment: 0001-Moved-list-reversion-into-static-function.patch
Description: Text Data

Attachment: signature.asc
Description: This is a digitally signed message part.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]