[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] [bug-wget] Compiling Wget on Windows

From: Ray Satiro
Subject: Re: [Bug-wget] [bug-wget] Compiling Wget on Windows
Date: Thu, 13 Jun 2013 21:53:08 -0700 (PDT)

> From: Bykov Aleksey <address@hidden>

>To: address@hidden
>Last time i had recieved error with wget bootstrap or configure (basic) in
>mingw long time ago...
>I use mingw-get-inst-20120426.exe and choose "download lastest repository
>packages". Components - "C compiler", "C++ compiler", "MSYS Basic System"
>and "MinGW Developer Toolkit". Install it to some new dir. Add folder
>"Source" with "wget" and "gnulib". Replace "_PC_NAME_MAX" with "256" in  

Also there's a patch for that on the parallel-wget branch, "MinGW compatibility 

>Then run
>./bootstrap --no-git --gnulib-srcdir=../gnulib 2>&1 | tee bootstrap.log
>(./configure --disable-nls --without-ssl --disable-iri 2>&1 && make 2>&1)|
>tee configmake.log

I stand corrected, the bootstrapping process appears to work properly with 
mingw now. I tested in a clean XP VM but I couldn't reproduce a build using 
your commands. Can you up your config.log? When I ran configure threads were 
enabled. Did you explicitly disable threads? Yours has:
checking for multithread API to use... none

but mine has:
checking whether imported symbols can be declared weak... no
checking pthread.h usability... yes
checking pthread.h presence... yes
checking for pthread.h... yes
checking for pthread_kill in -lpthread... yes
checking for multithread API to use... posix

Otherwise the configure output is almost identical. Then I ran make and it 
failed because -lpthread wasn't added. saw a lot of this:

../lib/libgnu.a(regex.o):regex.c:(.text+0xa4e5): undefined reference to 

compiles once added:
gcc  -O2 -Wall   -o wget.exe cmpt.o connect.o convert.o cookies.o ftp.o css_.o 
css-url.o ftp-basic.o ftp-ls.o hash.o host.o html-parse.o html-url.o http.o 
init.o log.o main.o netrc.o progress.o ptimer.o recur.o res.o retr.o spider.o 
url.o warc.o utils.o exits.o build_info.o  version.o ftp-opie.o mswindows.o 
../lib/libgnu.a -lws2_32 -lpthread

I can do --enable-threads=windows or --disable-threads but if I don't do either 
or I do --enable-threads=posix then posix is enabled and the build fails due to 
missing pthread lib.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]