[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] Multiple --accept-regex don't working

From: Ángel González
Subject: Re: [Bug-wget] Multiple --accept-regex don't working
Date: Sat, 14 Sep 2013 01:40:45 +0200
User-agent: Thunderbird

On 13/09/13 18:34, Nicolas Rodsevich wrote:
I tried to use 2 --accept-regex directives, but Wget used just the last one, I 
had to combine both in order to have the job done.
Maybe this isn't a bug, but it would be nice to have Wget matching multiple 
regexs rather than combining them in just one directive.

First tried directives command:
--accept-regex '.*mod/resource/.*' --accept-regex '.*/mod_resource/content/.*'

Finally used regex:
--accept-regex '.*mod.*resource/.*'

Thank you all
Seems a good idea. Combining two accept regex is equivalent to joining them with pipes, so in the above example: '.*mod/resource/.*|.*/mod_resource/content/.*' (although '.*(mod/resource|/mod_resource/content)/.*' is obviously an equivalent regex performing better)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]