[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] [bug-wget] Unable to execute the Test Suite

From: Yousong Zhou
Subject: Re: [Bug-wget] [bug-wget] Unable to execute the Test Suite
Date: Fri, 21 Feb 2014 22:43:46 +0800 (China Standard Time)
User-agent: Alpine 2.11 (WNT 23 2013-08-11)


On Fri, 21 Feb 2014, Darshit Shah wrote:

Hi all,

I was trying to run the test suite on Wget, but it keeps failing due to the
new submodule. At first I thought the issue was probably with the
parallel-wget branch, so I switched to master. Yet the same problem. Just
as a control test, I created a new clone of the repository and I am still
facing the same problem.

The error output is:

echo 1.15.6-d682 > .version-t && mv .version-t .version
if test -d ./.git                               \
       && git --version >/dev/null 2>&1; then                  \
 cd . &&                                               \
 git submodule --quiet foreach                                 \
     test '"$(git rev-parse "$sha1")"'                 \
     = '"$(git merge-base origin "$sha1")"'                    \
   || { echo 'maint.mk: found non-public submodule commit' >&2;        \
        exit 1; };                                             \
else                                                            \
 : ;                                                           \
Stopping at 'gnulib'; script returned non-zero status.
maint.mk: found non-public submodule commit
maint.mk:1394: recipe for target 'public-submodule-commit' failed
make: *** [public-submodule-commit] Error 1

This happens only when running `make check` and not when trying to
otherwise compile from source.

Mine worked fine after doing `git clean -f -d'. Have you tried run the command manually to see the actuall output of each elements?

  git submodule foreach                                 \
      test '"$(git rev-parse "$sha1")"'                 \
      = '"$(git merge-base origin "$sha1")"'            \

Or something like

  git submodule foreach                         \
      echo '$name, $path, $sha1'

which produces

  address@hidden:~/wget$ git submodule foreach  \
  >       echo '$name, $path, $sha1'
  Entering 'gnulib'
  gnulib, gnulib, 0ac90c5a98030c998f3e1db3a0d7f19d4630b6b6

on my machine.


Anyone know the reasons for this?

Thanking You,
Darshit Shah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]