[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] Why is wget appending a .1 on the first download attempt?

From: Jerry Cheung
Subject: Re: [Bug-wget] Why is wget appending a .1 on the first download attempt?
Date: Mon, 23 Jun 2014 09:51:52 -0700

Here's the output of my version (1.14) and the wget run. Strangely, I don't
see a `-d` debug flag and couldn't find one in help:

$ wget --version
GNU Wget 1.14 built on darwin13.0.0.

+digest +https +ipv6 -iri +large-file -nls +ntlm +opie +ssl/openssl

    /opt/boxen/homebrew/etc/wgetrc (system)
Compile: cc -DHAVE_CONFIG_H
    -DLOCALEDIR="/opt/boxen/homebrew/Cellar/wget/1.14/share/locale" -I.
    -I../lib -I../lib -O2 -Wall
Link: cc -O2 -Wall -lssl -lcrypto -lz -ldl -lz -lz ftp-opie.o openssl.o
    http-ntlm.o ../lib/libgnu.a

Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Originally written by Hrvoje Niksic <address@hidden>.
Please send bug reports and questions to <address@hidden>.

$ wget -N -E http://www.whatcodecraves.com/posts
--2014-06-23 09:49:28--  http://www.whatcodecraves.com/posts
Resolving www.whatcodecraves.com...
Connecting to www.whatcodecraves.com||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 12598 (12K) [text/html]
Saving to: ‘posts.1.html’

12,598      --.-K/s   in 0s

Last-modified header missing -- time-stamps turned off.
2014-06-23 09:49:28 (27.8 MB/s) - ‘posts.1.html’ saved [12598/12598]

$ wget -d -N -E http://www.whatcodecraves.com/posts
wget: invalid option -- 'd'
Usage: wget [OPTION]... [URL]...

Try `wget --help' for more options.

On Mon, Jun 23, 2014 at 12:31 AM, Giuseppe Scrivano <address@hidden>

> Jerry Cheung <address@hidden> writes:
> > I ran the following:
> >
> > wget -N -E http://whatcodecraves.com/articles
> >
> > The output was saved to `articles.1.html`. Why is there a `.1` on this
> > initial run?
> I've tried the command here and it works for me, wget writes to
> articles.html.
> What version of wget are you using?  Can you use -d and post the log
> here?
> Thanks,
> Giuseppe

@whatcodecraves <http://twitter.com/whatcodecraves>
GitHub <https://github.com/jch>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]