[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] glibc detected

From: Ray Satiro
Subject: Re: [Bug-wget] glibc detected
Date: Sat, 28 Jun 2014 13:43:15 -0400
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0

On 6/28/2014 10:13 AM, Giuseppe Scrivano wrote:
Martin Jašek <address@hidden> writes:


when I run wget like:

wget -q -O spoje.html
I've tried this command line in a loop here (200 times) but I wasn't
able to reproduce it even once.  I've also tried on a Debian machine
(though 64 bits) with the same version of wget as yours but I couldn't
reproduce the problem there as well.

I tried in two VMs Ubuntu 13.10 x64 (wget 1.14) and Ubuntu 14.04 x64 LTS (wget 1.15).

In Ubuntu 13.10 / wget 1.14 there's some weird behavior and the outcome differs but I can't get a crash. For example
URI content encoding = None
idn_encode failed (3): ‘Non-digit/letter/hyphen in input’
--2014-06-28 12:49:30--  http://8b%01/
conaddr is:
Resolving 8b\001 (8b\001)... failed: Name or service not known.
wget: unable to resolve host address ‘8b\001’
[IRI fallbacking to non-utf8 for ‘http://8b%01/’

From what I can see the server is returning the same 302 data every time though. Also I found this which may be related http://savannah.gnu.org/bugs/?38960

In Ubuntu 14.04 / wget 1.15 I don't see anything unusual. Logs are attached with version information and --debug output and a valgrind on Ubuntu 13.10/wget 1.14 but I don't have the debugging package.. did you mean wget debug package Petr?

Attachment: wget logs.zip
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]