[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] retrieval failure:Forbidden? for UTF-8-URL in wget that w

From: L Walsh
Subject: Re: [Bug-wget] retrieval failure:Forbidden? for UTF-8-URL in wget that works on FF and IE
Date: Wed, 08 Jun 2016 13:26:32 -0700
User-agent: Thunderbird

Tim Rühsen wrote:
On Wednesday 08 June 2016 11:47:46 L. A. Walsh wrote:
I tried:

wget "http://translate.google.com/#ja/en/クイーンズブレイド・メインテーマB";

But get a an Error "403: Forbidden" (tried w/ and w/o proxy) -- same.

But cut/paste the same URL into IE11 or
PaleMoon (a 64-bit FF derivative), and it works.

Any idea why or what I might do to get it to work?

Basically, from '#' on (fragment part of URL) nothing is relevant for the HTTP request. This is what Firefox 46 sends to localhost:8080 (I started a netcat 'nc -l -p 8080' to make sure).
Sounds like FF46 is broken.

        It is in PaleMoon, IE11 and GoogleChrome.  All of them fetch
the URL when pasted into the address box.

If I do a 'telnet translate.google.com 80' and paste the above (just with 'Host: translate.google.com' and an empty line at the end):
AFAIK, telnet doesn't support anything but ascii.

My guess is, that google does not like User-Agent 'wget', now trying with Firefox's User-Agent: $ wget -d -U "Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0" http://translate.google.com

And zack ... that works. Give it a try.

Regards, Tim
        Oh frack!   I thought the days of client-censoring were over
when MS stopped doing it.   Now Google is the new MS??  Frack.
That sucks.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]