[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] Output no longer going to stderr

From: Barry Kauler
Subject: Re: [Bug-wget] Output no longer going to stderr
Date: Mon, 22 May 2017 11:19:15 +0800

On 5/21/17, Tim Rühsen <address@hidden> wrote:
> On Sonntag, 21. Mai 2017 10:06:28 CEST Barry Kauler wrote:
>> Hi guys,
>> I recently upgraded wget to 1.19.1, but have discovered that it has
>> broken some of my scripts.
>> These are scripts that expect output on stderr. For example, have
>> "wget ... 2> logfile" or "wget ..... 2>&1 | .... "
>> Instead, I just get text message "Redirecting output to ‘wget-log.1’",
>> and get a logfile at ~/wget-log.1
> I can't reproduce that with 1.19.1, also not with the command posted at the
> link below.
> What system are you on  and what is your complete command line ?
> With Best Regards, Tim
>> Is there a good reason for this change?
>> If not, I would like the old behaviour back please.
>> I see someone else has posted about this:
>> https://www.makemkv.com/forum2/viewtopic.php?f=3&t=15885
>> Regards,
>> Barry Kauler

This is the line in a shell script, that has worked for years, now broken:

 LANG=C wget -4 -t 2 -T 20 --waitretry=20 --spider -S "${URLSPEC}" >
/tmp/download_file_spider.log1 2>&1

I am running an experimental distribution, compiled in OpenEmbedded
(that Yocto uses).

I notice commits late in 2016 that look like they might be the cause.
HOWEVER, the problem has disappeared.

Like magic, today I repeated the exact same operation, to download a
file as per the above line from the script, this time it worked.
What that line above does, is log some details about the file, that
are then checked, before the actual download.

So, mystery, how did I get that problem temporarily, and how did that
other guy get it also?

It has got me worried, so I have rolled back to wget 1.17.1, at least for now.

Barry Kauler

reply via email to

[Prev in Thread] Current Thread [Next in Thread]