[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-wget] [bug #51626] Configure scripts didn't check for availabilty o

From: Nutchanon Wetchasit
Subject: [Bug-wget] [bug #51626] Configure scripts didn't check for availabilty of gperf, leading to make failure
Date: Mon, 31 Jul 2017 08:41:58 -0400 (EDT)
User-agent: Mozilla/5.0 (X11; Linux i686; rv:25.8) Gecko/20151123 Firefox/31.9 PaleMoon/25.8.1


                 Summary: Configure scripts didn't check for availabilty of
gperf, leading to make failure
                 Project: GNU Wget
            Submitted by: nachanon
            Submitted on: Mon 31 Jul 2017 07:41:57 PM ICT
                Category: Build/Install
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: 
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 1.19.1
        Operating System: GNU/Linux
         Reproducibility: Every Time
           Fixed Release: None
         Planned Release: None
              Regression: None
           Work Required: None
          Patch Included: None



While I was compiling lastest release version of Wget (1.19.1) via Git
checkout to verify a URL filtering issue, I ran into a build failure.

>From a look at output from Make, it turned out that Make somehow tried to
invoke `gperf` command, and failed as I didn't have gperf installed on my
system. Gperf <https://www.gnu.org/software/gperf/> requirement is *not
mentioned anywhere in documentation*: README
file. Also, *both `bootstrap` and `configure` didn't complain about it* being
missing either.

Exact steps to reproduce:

* Uninstall `gperf` (if installed)
* Run `git clone https://git.savannah.gnu.org/git/wget.git wget.git`
* Go into `wget.git` directory
* Run `git checkout v1.19.1`
* Run `./bootstrap`
* Run `./configure --prefix=/opt/wget-1.19.1 --enable-assert`
* Run `make V=1`

You would see that Make ends with an error like following:

gperf -m 10 ./unicase/special-casing-table.gperf >
./unicase/special-casing-table.h-t && \
        mv ./unicase/special-casing-table.h-t ./unicase/special-casing-table.h
/bin/bash: gperf: command not found
make[2]: *** [unicase/special-casing-table.h] Error 127
make[2]: Leaving directory `/home/window/prog/wget.git/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/window/prog/wget.git'
make: *** [all] Error 2

Bootstrap output, configure output, config.log, and full Make output are
attached as `wget1.19.1git-gperferror.zip` for a reference.

If `gperf` was installed, the build would succeed. This problem affects only
Git version of Wget; the tarball version builds fine.

Wget: 1.19.1 (git)
Gnulib: v0.1-1130-g916a632 (git)
Autoconf: 2.69-1 (debian)
Gperf: 3.0.3-1+b1 (debian)
System: Debian GNU/Linux 7.0 Wheezy i386


File Attachments:

Date: Mon 31 Jul 2017 07:41:57 PM ICT  Name: wget1.19.1git-gperferror.zip 
Size: 96KiB   By: nachanon
Bootstrap, configure, and build logs


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]