[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] Unexpected wget -N behaviour for 1.17 onwards?

From: Tim Rühsen
Subject: Re: [Bug-wget] Unexpected wget -N behaviour for 1.17 onwards?
Date: Sun, 10 Feb 2019 12:19:32 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.5.0

Hi Lawrence,

please try again with --no-if-modified-since. That should revert to the
old behavior of using two requests (HEAD and then GET).

If you still see issues, let us know.

Some servers/proxies don't like the If-Modified-Since header.

Regards, Tim

On 10.02.19 08:11, Lawrence Wade wrote:
> Hi Everyone,
> This might be a corroboration of this
> http://lists.gnu.org/archive/html/bug-wget/2018-10/msg00049.html
> and this
> https://bugs.launchpad.net/ubuntu/+source/wget/+bug/1715481
> I use wget to backup my cellphone running Palapa Web Server, and it
> has worked well for me for years. Since upgrading to OpenSUSE Leap 15,
> I have been having corrupted files.
> My method is
> $ wget -r -N
> and if the connection is interrupted for any reason, the next time I
> call wget it would complete any incomplete files. And since Leap 15, I
> have been getting gradually corrupted backups. I was tearing my hair
> out looking at wgetrc and other things.
> With one long file that I knew was incomplete, I got a Not Modified -
> omitting download, even though I knew the file sizes were different
> between the server and wget's copy - though the wget man page
> explicitly states that if the file sizes do not match, -N will trigger
> a download.
> I tried on OpenSUSE 42.3 (wget 1.14) and the incomplete file triggered
> a download, even though wgetrc was identical.
> Again, on Leap 15, I compiled 1.20.1 (latest), 1.17.1, and then
> finally with 1.16.3 the behaviour went back to what I expected (and I
> got my corrupted phone backups fixed).
> Was a bug possibly introduced in 1.17 with the support for 
> --if-modified-since?
> Version shipping with OpenSUSE Leap 15:
> GNU Wget 1.19.5 built on linux-gnu.
> +cares +digest +gpgme +https +ipv6 +iri +large-file +metalink +nls
> +ntlm +opie +psl +ssl/openssl
> Last version I tried where "wget -r -N" works as expected:
> GNU Wget 1.16.3 built on linux-gnu.
> +digest +https +ipv6 -iri +large-file +nls +ntlm +opie +psl +ssl/gnutls
> I'm open to the possibility that there may be something else causing
> this bug, I have not found many mentions of it, but then again it is
> subtle. You get pretty confident when you just let wget do its thing,
> so there may be a lot of incomplete files out there... :)
> Thanks so much for your help. I can provide any other info that would
> be helpful.
> Lawrence Wade
> Ottawa, Canada

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]