[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-hackers] [Chicken-users] Windows 10, mingw-w64, chicken 4.1

From: Claude Marinier
Subject: Re: [Chicken-hackers] [Chicken-users] Windows 10, mingw-w64, chicken 4.11, "invalid encoded numeric literal"
Date: Thu, 25 Aug 2016 19:54:48 -0400

Hello again,

I don't know if GMail will top post. If it does, I apologize.

I observed the same error when I built chicken 4.11.0 using just MinGW 64-bit from the Windows command line (no MSys).

There were interesting differences. The csi built from MSys just hangs. The one built without MSys runs but behaves strangely. Adding one digit to a simple _expression_ caused it to hang.

With numbers, (1.0 0.123456789 /) works but (1.0 0.1234567890 /) hangs. Without numbers, all is well. I tried a bunch of things and am convinced that adding that extra digit makes the difference. I built a small program; it was also hanging. I reduced it down to that _expression_.

Using chicken built without MSys, I can install the numbers egg and my program behaves normally until I use a number with 11 significant digits.

Is there a dot release after 4.11.0, like 4.11.1? If there is, I would like to try it.

Thank you.

On 24 August 2016 at 20:27, Claude Marinier <address@hidden> wrote:
On Tue, 23 Aug 2016, Claude Marinier wrote:
>On Thu, 18 Aug 2016, Dan Leslie wrote:
>> I have used it successfully with MSys2 and Mingw-w64; the details
>> are here:
> Hi Dan,
> I uninstalled MinGW-W64 & MSYS2, rebooted, and installed MSYS2 according to
> your instructions. The result is similar: the build works but check fails
> line this.
> Note: in toplevel procedure `doloop765':
>   (lolevel-tests.scm:184) in procedure call to `locative?', the predicate
> is called with an argument of type `locative' and will always return true
> ""gcc" "a.c" -o "a.o" -c  -fno-strict-aliasing -fwrapv
> -IC:/msys64/home/claude/chicken-4.11.0/tests/..
> -IC:\\msys64\\usr\\local\\include\\chicken\\"
> rm a.c
> ""gcc" "a.o" -o "a.out" -Wl,--enable-auto-import
> -LC:/msys64/home/claude/chicken-4.11.0/tests/.. -LC:\msys64\usr\local\lib\
> -lchicken -lm -lws2_32"
> rm a.o
> [panic] invalid encoded numeric literal - execution terminated
> make: *** [rules.make:663: check] Error 1
> I am running Windows 10, 64-bit on an old HP EliteBook.
> Is there a known problem with gcc 6.1.0? Or are HP laptops quirky?


I am normally on chicken users. Someone there (Dan) suggested I post here.

Do you have any idea what I can do to get a working chicken?

Thank you.

Claude Marinier

Claude Marinier

reply via email to

[Prev in Thread] Current Thread [Next in Thread]