commit-classpath
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: classpath/java/io DataInputStream.java DataOutp...


From: Mark Wielaard
Subject: Re: classpath/java/io DataInputStream.java DataOutp...
Date: 02 Mar 2003 12:41:14 +0100

Hi,

On Sun, 2003-03-02 at 02:24, Aaron M. Renn wrote:
>       DataInputStream:
>       o Fix word-wrapped comments
>       o Remove all convert* methods except UTF and inline functionality
>       o Add synchronization on shared buffer utilization
>       
>       DataOutputStream
>       o Remove all convert* methods except UTF and inline functionality
>       o Adopt shared conversion buffer approach a la DataInputStream
>       Synchronize accordingly
>       o Re-indent code
>       o Eliminate word-wrapped comments
>       
>       RandomAccessFile
>       o Inline converter functionality previously supplied by static methods
>       in Data{Input,Output}Stream - except UTF conversion
>       o Re-ident code
>       o Eliminate word-wrapped comments

Thanks for cleaning this up. You must add a real ChangeLog entry to the
(toplevel) ChangeLog file though.

Do we need the synchronisation? I don't believe the DataXputStream
classes are guaranteed to do anything meaningful when concurrently used
from multiple Threads. And losing the synchronisation helps a lot on VMs
that have slow locking primitives.

Please split reindentation of code and actual changes to the code in the
future this makes the diffs far more readable.

You are right that we should move to new String(byte[], "UTF-8") and
String.getBytes("UTF-8") as soon as possible (when java.nio.charset has
been completed, including a reliable UTF-8 converter).

Cheers,

Mark





reply via email to

[Prev in Thread] Current Thread [Next in Thread]