commit-classpath
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

FYI: Patch: java.lang.Class


From: Michael Koch
Subject: FYI: Patch: java.lang.Class
Date: Sun, 25 Jan 2004 16:10:07 +0100
User-agent: KMail/1.5.4

Hi list,


I commited the attached little patch to merge more with libgcj's version. It 
simply renames some variables and puts a code duplication into its own 
method.


Michael


2004-01-25  Michael Koch  <address@hidden>

        * java/lang/Class.java
        (getDeclaredMethod): Renamed argument "name" to "methodName".
        (getField): Renamed argument "name" to "fieldName".
        (getResource): Renamed argument "name" to "resourceName".
        Call resourcePath() instead of doing the work here.
        (getResourceAsStream): Renamed argument "name" to "resourceName".
        Call resourcePath() instead of doing the work here.
        (resourcePath): New method.

Attachment: class.diff
Description: Text Data


reply via email to

[Prev in Thread] Current Thread [Next in Thread]