[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Debian-sf-devel] RE: Project approval problem

From: William F. Seipel
Subject: Re: [Debian-sf-devel] RE: Project approval problem
Date: Tue, 19 Feb 2002 23:38:55 -0600
User-agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4) Gecko/20011019 Netscape6/6.2

I started looking in some of the error logs

[Tue Feb 19 06:25:26 2002] [notice] Apache/1.3.23 (Unix) Debian GNU/Linux PHP/4
[Tue Feb 19 06:25:26 2002] [notice] suEXEC mechanism enabled (wrapper: /usr/lib
[Tue Feb 19 06:25:26 2002] [notice] Accept mutex: sysvsem (Default: sysvsem)
VVVVVVVVVV---below is what was generated after I press the approve button in sourceforge
LDAP: No such object
        matched DN: "dc=homeforge,dc=hom"
additional info: parent does not exist
LDAP: No such object
        matched DN: "dc=homeforge,dc=hom"
        additional info: parent does not exist
these errors appear when the approve button is selected

Christian BAYLE wrote:
I have got
slapd 2.0.21-3 OpenLDAP server (slapd).
And the same kind of problem
The fact you could create a user shows it was working
Try /etc/init.d/ncsd stop
/etc/init.d/slapd stop
sleep 30
/etc/init.d/slapd start
sleep 30
/usr/lib/sourceforge/bin/ reset
/usr/lib/sourceforge/bin/ configure
/usr/lib/sourceforge/bin/ update

/usr/lib/sourceforge/bin/ list
Should show you groups and users you created

As it's not systematic and deep in ldap php4 module, it's difficult
to correct, even to bug report.
I encourage you to reproduce this on a minimal example and bug report to
the debian BTS


"William F. Seipel" wrote:
I could be more clear in my emails, it still is not working, maybe I
should look for a more stable verison of LDAP

I did a get-apt upgrade, still the same problem list gives the same results

SLAPD 2.0.23-1 is the version i am using

Christian BAYLE wrote:


I have got the same kind of problems
I restarted slapd and then things came ok
Maybe this is linked with nscd deamon
It's seems that ldap is rather unstable at the moment.

"William F. Seipel" wrote:

Bill originally said

I did a fresh install of the 2.6+0.6 packages

when asked to setup the ldap domain stuff I used the
main system host name and domain
eg (at work) dc=pdc01,dc=nwd-mr,dc=usace,dc=army,dc=mil
eg (at home internal network lan) dc=homeforge,dc=hom

And then I was able to setup a new user,
I was able to login with the new user name
I registered a project successfully
I then logged in as the admin
then went to approve it with the admin account and I got the

Warning: LDAP: Unable to bind to server: Invalid credentials in
/usr/lib/sourceforge/common/include/ldap.php on line 125

Fatal error: Call to undefined function: /dev/null() in
/usr/lib/sourceforge/common/include/ldap.php on line 425
Open transaction detected!!!

Christian said

Check that ldap is working,
it might be ok since you manage to install
Maybe you have a wrong passwd in the /etc/sourceforge/ file
that should be the same than /etc/ldap.secret
Or there is something broken in ldap,
which version of ldap do you use?


Bill's response
Here is a listing of /usr/lib/sourceforge/bin/ list
homeforge:/home/seipel# /usr/lib/sourceforge/bin/install-ldap list
version: 2

# filter: (objectclass=*)
# requesting: ALL

# homeforge, hom
dn: dc=homeforge,dc=hom
objectClass: top
objectClass: domain
dc: rd

# People, homeforge, hom
dn: ou=People, dc=homeforge,dc=hom
objectClass: top
objectClass: organizationalUnit
ou: People

# search result
search: 2
result: 0 Success

# numResponses: 3
# numEntries: 2

I have checked the password in /etc/sourceforge/
and in /etc/ldap.secret they checkout.

I have done the purge/reset/configure

I have fooled around with named for my little lan, that seems to work
during the sourceforge install it complained about reverse dns not working

I couldn't figure out the version of LDAP (slapd) though I am sure it is
bleeding edge it was from unstable debian

Thanks for your help
I wont give up until this is solved

Debian-sf-devel mailing list

Debian-sf-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]