[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Debian-sf-devel] Re: [Debian-sf-users] New Pre-Release 2.6-0+7

From: Soon-Son Kwon
Subject: [Debian-sf-devel] Re: [Debian-sf-users] New Pre-Release 2.6-0+7
Date: Wed, 27 Feb 2002 21:12:18 +0900
User-agent: Mutt/1.2.5i

On Wed, Feb 27, 2002 at 08:51:33AM +0100, Christian BAYLE wrote:
> Soon-Son Kwon wrote:
> > 
> > On Tue, Feb 26, 2002 at 07:41:44PM +0100, Christian BAYLE wrote:
> > > A new pre-release of 2.6 beta version is available on my site
> > >
> > >
> > >
> > > This is supposed to correct ldap stuffs
> > > You will need last slapd and libnss-ldap from sid
> > > I recommend you to purge slapd (apt-get remove --purge slapd)
> > > And to take care when asked for domain in slapd, to fill with your FQDN
> > > ( not the default, that is your domain name)
> > > Answer with default answers for other questions should be OK
> > 
> > Current ldap package of sid does not ask anything....
> > It just lets me know the system set the admin password
> > and does not show those dialogue boxes regarding the configuration.
> > Even if I run "dpkg-reconfigure slapd", it says like this:
> > "ldap is running. remove /etc/ldap/slapd.conf or remove the
> > package and try again"
> You can dpkg-reconfigure debonf to change questions settings
> You can also apt-get remove --purge slapd
> This will also desinstall sourceforge 
> > If I remove /etc/ldap/slapd.conf and rerun it, it shows the same
> > boxes that I met on woody but sed-related error occurs.
> > (sed complains that /etc/ldap/slapd.conf does not exist)
> > If I remove the package and reinstall it, nothing changes.
> > 
> Unfortunatly slapd don't reconfigure, the only thing to do is either:
> -completly purge the package
> -recreate ldap.conf by hand
> /usr/lib/sourceforge/bin/ reset reinitialize ldap db
> but is not able to recreate ldap.conf

I was using woody but to test this, upgraded to sid but still fails.
Error occurs at the same location (

On another woody machine, I installed 2.6_0+7 with "force-all"
option but seems that ldap stuff still causes problem.
(the installation procedure of 2.6_0+7 is more verbose than 2.5.X)

....blah blah blah....
Stopping OpenLDAP: slapd.
Starting OpenLDAP: slapd.
Load ldap
Distinguished Name is dc=www,dc=myhome,dc=lan
Creating ldif file from database
Filling LDAP with database
Setup SF_robot account
Adding robot accounts
ldap_bind: Invalid credentials
LDAP Server OK : dn=dc=www,dc=myhome,dc=lan
Changing SF_robot passwd using admin account
ldap_initialize( <DEFAULT> )
ldap_bind: Invalid credentials
dpkg: error processing sourceforge (--install):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:

This is the same error which I encountered so far.

The hostname of the test machine is www.myhome.lan and whether 
I set the base dn to "dc=www,dc=myhome,dc=lan" or 
"dc=myhome,dc=lan", adding robot account fails. I have got the same 
"ldap_bind: Invalid credentials" error for 2.5.23/2.5.25/2.6.07....

Can anybody send me the working copy of /etc/ldap/slapd.conf
and some other necessary /etc/sourceforge/* configuration files
so that I can compare my configuration?

Thanks very much....

p.s. Anthoine...I am curious to know how's it going on your side... :-)
           (o_             **WTFM**
(o_  (o_   //\
(/)_ (/)_  V_/_

reply via email to

[Prev in Thread] Current Thread [Next in Thread]