[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[dev-serveez] libtool 1.5 used in serveez package

From: stefan
Subject: [dev-serveez] libtool 1.5 used in serveez package
Date: Sun, 25 May 2003 22:09:57 +0200 (CEST)

Dear Libtool'ers,

first of all: thanks a lot for the improved support for mingw32 in the new
libtool version, especially for the 'gcc -shared' usage...
Trying to update the serveez's configure system to Autoconf 2.57, Automake
1.7.5 and libtool 1.5 I bumped into a single problem with libtool.  With
the previous version (1.4.2) it worked.  Now it doesn't anymore.  I am
using a mingw cross compiler on a i586-linux to compile the serveez
package for mingw32.

When I use libtool 1.5 out of the box I get this error message:


/bin/sh ../../libtool --mode=link i386-mingw32-gcc  -g -O2   -o -rpath /tmp/svz/lib -export-dynamic -no-undefined -release
0.1.5 alloc.lo util.lo snprintf.lo hash.lo sparsevec.lo tcp-socket.lo
pipe-socket.lo udp-socket.lo icmp-socket.lo raw-socket.lo server-core.lo
server-loop.lo windoze.lo boot.lo server.lo server-socket.lo interface.lo
dynload.lo vector.lo core.lo socket.lo array.lo portcfg.lo binding.lo
passthrough.lo cfg.lo asprintf.lo coserver/
codec/  -liberty  -ladvapi32 -lshell32 -luser32 -lws2_32

*** Warning: linker path does not have real file for library -liberty.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libiberty and none of the candidates passed a file format test
*** using a file magic. Last file checked:
*** The inter-library dependencies that have been dropped here will be
*** automatically added whenever a program is linked with this library
*** or is declared to -dlopen it.

*** Since this library must not contain undefined symbols,
*** because either the platform does not support them or
*** it was explicitly requested with -no-undefined,
*** libtool will only create a static version of it.


This message indicates that libtool is not able/does not want to link the
static archive libiberty.a to the libserveez.dll.  This worked perfectly
with 1.4.2.  When looking at the magic_regex_expr ('file_magic ^x86
archive import|^x86 DLL') in libtool.m4 one can get the impression that
windows dlls are now allowed to be linked against other dlls only.  Static
archives are not allowed anymore.  Has this some reason?

For now I modified libtool.m4 to use 'file_magic ^x86 archive import|^x86
DLL|^x86 archive static' instead.  Then everything works fine.

Is this a bug or a feature?

Thanks in advance,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]